synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruwan Linton <ruwan.lin...@gmail.com>
Subject Re: Error at Synapse startup
Date Sun, 01 Aug 2010 13:37:11 GMT
Hi Andreas,

I guess we should change the version to 1.2.9, since we are expecting to go
for the 2.0 release soon after the respective axis2, and other module
releases like Sandesha and Rampart.

Let me try to get the WSO2 repo issue sorted at the mean time.

Thanks,
Ruwan

On Sun, Aug 1, 2010 at 3:49 PM, Andreas Veithen
<andreas.veithen@gmail.com>wrote:

> On Sun, Aug 1, 2010 at 06:49, Charith Wickramarachchi
> <charith.dhanushka@gmail.com> wrote:
> > Thanks a lot. Replacing Axiom jars with 1.2.10-SNAPSHOT solved the start
> up
> > issue in my version.
> > but it may cause some other runtime errors in synapse since it need to be
> > ported to new version of Axiom properly (i didn't get any yet :) ).
>
> No, Axiom 1.2.9 has been released only a couple of weeks ago. Before
> the release, there were fresh 1.2.9-SNAPSHOT versions in the Apache
> snapshot repository and Synapse should have used them. Since the
> release, not much has happened in Axiom trunk. Therefore,
> 1.2.10-SNAPSHOT is almost identical to 1.2.9 and thus the last
> 1.2.9-SNAPSHOT version that was available in the Apache snapshot
> repository.
>
> > On Sat, Jul 31, 2010 at 3:47 PM, Andreas Veithen <
> andreas.veithen@gmail.com>
> > wrote:
> >>
> >> That is probably caused by two factors:
> >>
> >> 1. The Synapse trunk uses the wrong version of Axiom, namely
> >> 1.2.9-SNAPSHOT. However, the Axis2 trunk has been switched to
> >> 1.2.10-SNAPSHOT.
> >> 2. The Synapse POMs refer to a Maven repository at WSO2 that contains
> >> completely outdated (08-Feb-2010) Axiom snapshots with version
> >> 1.2.9-SNAPSHOT. On the other hand, since Axiom trunk is at version
> >> 1.2.10-SNAPSHOT, the Apache snapshot repository no longer contains
> >> 1.2.9-SNAPSHOT (Nexus automatically removes outdated snapshots).
> >>
> >> Depending on the state of your local Maven repository, you will
> >> therefore end up running Synapse with a current Axis2 snapshot and a 6
> >> month old Axiom snapshot. Not surprising that this fails.
> >>
> >> I'm hesitating between changing the axiom.version property in the
> >> Synapse POMs to 1.2.10-SNAPSHOT (or 1.2.9) and removing the dependency
> >> altogether so that it comes in as a transitive dependency through
> >> Axis2 (with whatever version is expected by Axis2).
> >>
> >> Andreas
> >>
> >> On Sat, Jul 31, 2010 at 11:00, Charith Wickramarachchi
> >> <charith.dhanushka@gmail.com> wrote:
> >> > Hi,
> >> > I m getting an runtime error while starting the synapse instance i got
> >> > from
> >> > building from trunk.
> >> > Following is the error
> >> > Exception in thread "main" java.lang.NoClassDefFoundError:
> >> > org/apache/axiom/util/UIDGenerator
> >> > at
> >> >
> org.apache.axis2.description.AxisOperation.<init>(AxisOperation.java:90)
> >> > at
> >> >
> org.apache.axis2.description.AxisOperation.<init>(AxisOperation.java:95)
> >> > at
> >> >
> >> >
> org.apache.axis2.description.TwoChannelAxisOperation.<init>(TwoChannelAxisOperation.java:52)
> >> > at
> >> >
> >> >
> org.apache.axis2.description.InOutAxisOperation.<init>(InOutAxisOperation.java:44)
> >> > at
> >> >
> >> >
> org.apache.synapse.Axis2SynapseController.deploySynapseService(Axis2SynapseController.java:554)
> >> > at
> >> >
> >> >
> org.apache.synapse.Axis2SynapseController.createSynapseEnvironment(Axis2SynapseController.java:329)
> >> > at org.apache.synapse.ServerManager.start(ServerManager.java:185)
> >> > at org.apache.synapse.SynapseServer.main(SynapseServer.java:65)
> >> > I tried this even after building the Axiom and Axis2-kernel and
> >> > rebuilding
> >> > synapse.
> >> > thanks ,
> >> > Charith
> >> >
> >> >
> >> > --
> >> > Charith Dhanushka Wickramarachchi
> >> > http://charithwiki.blogspot.com/
> >> >
> >> >
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
> >> For additional commands, e-mail: dev-help@synapse.apache.org
> >>
> >
> >
> >
> > --
> > Charith Dhanushka Wickramarachchi
> > http://charithwiki.blogspot.com/
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
> For additional commands, e-mail: dev-help@synapse.apache.org
>
>


-- 
Ruwan Linton
Software Architect & Product Manager, WSO2 ESB; http://wso2.org/esb
WSO2 Inc.; http://wso2.org

Lean . Enterprise . Middleware

phone: +1 408 754 7388 ext 51789
email: ruwan@wso2.com; cell: +94 77 341 3097
blog: http://blog.ruwan.org
linkedin: http://www.linkedin.com/in/ruwanlinton
google: http://www.google.com/profiles/ruwan.linton
tweet: http://twitter.com/ruwanlinton

Mime
View raw message