synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruwan Linton <ruwan.lin...@gmail.com>
Subject Re: svn commit: r769518 - in /synapse/trunk/java: modules/transports/pom.xml pom.xml
Date Fri, 01 May 2009 14:22:39 GMT
Yes this fixes the logging issue and your reasoning is indeed correct :-)

Thanks,
Ruwan

On Fri, May 1, 2009 at 5:07 PM, Andreas Veithen
<andreas.veithen@gmail.com>wrote:

> What happened is that log4j disappeared from the distribution because
> it is no longer a transitive dependency. I added it as an explicit
> dependency of the distribution and this solves the problem for the log
> format. This makes sense because the individual JARs we include in the
> distribution should only depend on commons-logging, but not on any
> particular logging implementation. It is only when we assemble the
> distribution that we decide which logging framework we want to use.
>
> Andreas
>
> On Fri, May 1, 2009 at 07:08, Ruwan Linton <ruwan.linton@gmail.com> wrote:
> > Andreas,
> >
> > I am not clear why... but there with this version of log4j it seems like
> the
> > console log is completely out of format and also the shutdown hook log is
> > not captured. This could be due to some other issue but when I run the
> build
> > with the 1.2.15 dependency I cannot see this issue.
> >
> > Anyone else seeing this or is this just local to me?
> >
> > Thanks,
> > Ruwan
> >
> > On Wed, Apr 29, 2009 at 1:26 AM, <veithen@apache.org> wrote:
> >>
> >> Author: veithen
> >> Date: Tue Apr 28 19:56:19 2009
> >> New Revision: 769518
> >>
> >> URL: http://svn.apache.org/viewvc?rev=769518&view=rev
> >> Log:
> >> Downgraded log4j from 1.2.15 (latest) to 1.2.14.
> >>
> >> Reason: 1.2.15 introduces additional transitive dependencies, some of
> >> which are not resolvable. For the build this can easily be addressed
> using
> >> an exclusion rule in the dependencyManagement entry for log4j. However,
> as
> >> Ruwan reported, this doesn't work with the IDEA Maven plugin, and I
> still
> >> see issues with the Eclipse plugin.
> >>
> >> Note that log4j was upgraded to the latest version by Asankha in
> r748973,
> >> along with other dependencies. Since there is probably no particular
> reason
> >> to prefer 1.2.15 over previous versions, we should use 1.2.14 so that we
> can
> >> avoid cluttering the POM files with exclusions rules.
> >>
> >> Modified:
> >>    synapse/trunk/java/modules/transports/pom.xml
> >>    synapse/trunk/java/pom.xml
> >>
> >> Modified: synapse/trunk/java/modules/transports/pom.xml
> >> URL:
> >>
> http://svn.apache.org/viewvc/synapse/trunk/java/modules/transports/pom.xml?rev=769518&r1=769517&r2=769518&view=diff
> >>
> >>
> ==============================================================================
> >> --- synapse/trunk/java/modules/transports/pom.xml (original)
> >> +++ synapse/trunk/java/modules/transports/pom.xml Tue Apr 28 19:56:19
> 2009
> >> @@ -185,12 +185,6 @@
> >>             <artifactId>axis2-transport-testkit</artifactId>
> >>             <version>${axis2.transport.version}</version>
> >>             <scope>test</scope>
> >> -            <exclusions>
> >> -                <exclusion>
> >> -                    <groupId>com.sun.jmx</groupId>
> >> -                    <artifactId>jmxri</artifactId>
> >> -                </exclusion>
> >> -            </exclusions>
> >>         </dependency>
> >>
> >>         <!-- HTTP transport dependencies -->
> >>
> >> Modified: synapse/trunk/java/pom.xml
> >> URL:
> >>
> http://svn.apache.org/viewvc/synapse/trunk/java/pom.xml?rev=769518&r1=769517&r2=769518&view=diff
> >>
> >>
> ==============================================================================
> >> --- synapse/trunk/java/pom.xml (original)
> >> +++ synapse/trunk/java/pom.xml Tue Apr 28 19:56:19 2009
> >> @@ -448,32 +448,6 @@
> >>                 <groupId>log4j</groupId>
> >>                 <artifactId>log4j</artifactId>
> >>                 <version>${log4j.version}</version>
> >> -                <exclusions>
> >> -                    <exclusion>
> >> -                        <groupId>javax.mail</groupId>
> >> -                        <artifactId>mail</artifactId>
> >> -                    </exclusion>
> >> -                    <exclusion>
> >> -                        <groupId>javax.jms</groupId>
> >> -                        <artifactId>jms</artifactId>
> >> -                    </exclusion>
> >> -                    <exclusion>
> >> -                        <groupId>com.sun.jdmk</groupId>
> >> -                        <artifactId>jmxtools</artifactId>
> >> -                    </exclusion>
> >> -                    <exclusion>
> >> -                        <groupId>com.sun.jmx</groupId>
> >> -                        <artifactId>jmxri</artifactId>
> >> -                    </exclusion>
> >> -                    <exclusion>
> >> -                        <groupId>oro</groupId>
> >> -                        <artifactId>oro</artifactId>
> >> -                    </exclusion>
> >> -                    <exclusion>
> >> -                        <groupId>junit</groupId>
> >> -                        <artifactId>junit</artifactId>
> >> -                    </exclusion>
> >> -                </exclusions>
> >>             </dependency>
> >>
> >>             <dependency>
> >> @@ -700,8 +674,8 @@
> >>             <type>jar</type>
> >>             <exclusions>
> >>                 <exclusion>
> >> -                    <groupId>com.sun.jmx</groupId>
> >> -                    <artifactId>jmxri</artifactId>
> >> +                    <groupId>log4j</groupId>
> >> +                    <artifactId>log4j</artifactId>
> >>                 </exclusion>
> >>             </exclusions>
> >>         </dependency>
> >> @@ -867,7 +841,9 @@
> >>         <JLex.version>0.0</JLex.version>
> >>         <!-- misc -->
> >>         <junit.version>3.8.2</junit.version>
> >> -        <log4j.version>1.2.15</log4j.version>
> >> +        <!-- Warning: log4j versions above 1.2.14 introduce additional
> >> transitive dependencies,
> >> +             some of which are not available from the Maven central
> >> repository. -->
> >> +        <log4j.version>1.2.14</log4j.version>
> >>         <xmlunit.version>1.1</xmlunit.version>
> >>         <derby.version>10.4.2.0</derby.version>
> >>         <wrapper.version>3.2.3</wrapper.version>
> >>
> >>
> >
> >
> >
> > --
> > Ruwan Linton
> > Senior Software Engineer & Product Manager; WSO2 ESB;
> http://wso2.org/esb
> > WSO2 Inc.; http://wso2.org
> > email: ruwan@wso2.com; cell: +94 77 341 3097
> > blog: http://ruwansblog.blogspot.com
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
> For additional commands, e-mail: dev-help@synapse.apache.org
>
>


-- 
Ruwan Linton
Senior Software Engineer & Product Manager; WSO2 ESB; http://wso2.org/esb
WSO2 Inc.; http://wso2.org
email: ruwan@wso2.com; cell: +94 77 341 3097
blog: http://ruwansblog.blogspot.com

Mime
View raw message