synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Asanka Abeysinghe <asan...@wso2.com>
Subject Message responses not working on the trunk
Date Fri, 27 Mar 2009 05:46:29 GMT
Hi,
I can see few problems in the trunk while testing the eventing changes 
that I'm working on. To verify it as a common problem I ran the sampe 
150 and got the same issue. It seems the response messages are not working.
Behavior is request sends to the target endpoint successfully but the 
client time outs.

Synapse Console dose not show any exceptions other than the following 
warnings.
Thx
- Asanka


2009-03-27 11:14:14,475 [-] [http-Sender I/O dispatcher-1] DEBUG 
ClientHandler HTTP connection [localhost/127.0.0.1:9000]: Input ready 
[Request Message ID : 
urn:uuid:510F7A9D738F4B943C1238132654425735001-5080259]
2009-03-27 11:14:14,477 [-] [http-Sender I/O dispatcher-1] DEBUG 
ConnectionPool Released a connection to host: localhost on port : 9000 
to the connection pool of current size : 1
2009-03-27 11:14:14,478 [-] [http-Sender I/O dispatcher-1] DEBUG 
ClientHandler HTTP connection [localhost/127.0.0.1:9000]: Content 
decoder [chunk-coded; completed: true]
2009-03-27 11:14:14,478 [-] [HttpClientWorker-1] DEBUG 
SynapseCallbackReceiver Callback removed for request message id : 
urn:uuid:FA45486E9EF364E2CA1238132653989. Pending callbacks count : 1
2009-03-27 11:14:14,478 [-] [HttpClientWorker-1]  WARN 
SynapseCallbackReceiver Synapse received a response for the request with 
message Id : urn:uuid:FA45486E9EF364E2CA1238132653989 But a callback is 
not registered (anymore) to process this response
2009-03-27 11:14:44,336 [-] [http-Listener I/O dispatcher-1] DEBUG 
ServerHandler HTTP connection [closed]: Closed
 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message