synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Asankha C. Perera (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (SYNAPSE-455) deadlock using dbreport mediator
Date Tue, 24 Mar 2009 19:20:50 GMT

     [ https://issues.apache.org/jira/browse/SYNAPSE-455?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Asankha C. Perera resolved SYNAPSE-455.
---------------------------------------

    Resolution: Invalid
      Assignee: Asankha C. Perera

This is not a defect. I can reproduce this with a 10 user concurrency and load, for default
settings. However when I tune the datasource for the load as follows, I was able to successfully
complete the load test.

                        <property name="maxactive" value="15"/>
                        <property name="poolstatements" value="true"/>



> deadlock using dbreport mediator
> --------------------------------
>
>                 Key: SYNAPSE-455
>                 URL: https://issues.apache.org/jira/browse/SYNAPSE-455
>             Project: Synapse
>          Issue Type: Bug
>    Affects Versions: 1.2
>         Environment: wso2esb v1.7.1, debian, x86 xen VM.
>            Reporter: harm verhagen
>            Assignee: Asankha C. Perera
>
> I'm experiencing something that looks like a deadlock in wso2esb.
> I have a sequence with a number of database accesses. (using mysql).
> Basicaly I want to store every message in a database.
> When stress testing the esb sometimes locks up, not processing any messages
> anymore.
> Only stop/start seems to help
> The logging seems to indicate its related to the databasepool management.
> For the exact sequence see:
> http://wso2.org/mailarchive/esb-java-user/2008-September/000881.html
> For a thread dump see:
> http://wso2.org/mailarchive/esb-java-user/2008-September/000889.html
> *how to reproduce*
> issue soap request with a stress test tool, 5 threads simultaneously doing a
> medium load (30-60 request/second)
> Its pretty reproducible, after a few thousends requests I get wso2 to hang.
> so withing a few minutes.
> *ESB logging*
> 2008-09-25 17:31:56,199 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBReportMediator End : DBReport mediator
> 2008-09-25 17:31:56,199 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBLookupMediator Start : DBLookup mediator
> 2008-09-25 17:31:56,199 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBLookupMediator Getting a connection from DataSource
> jdbc:mysql://localhost:3306/esb and preparing statement : select id from
> transaction_uuid where uuid = ?
> 2008-09-25 17:31:56,200 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBLookupMediator Setting as parameter : 1 value :
> urn:uuid:953256D70E1C3B31A21222356730663 as JDBC Type : 12(see
> java.sql.Types for valid types)
> 2008-09-25 17:31:56,200 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBLookupMediator Successfully prepared statement : select id from
> transaction_uuid where uuid = ? against DataSource :
> jdbc:mysql://localhost:3306/esb
> 2008-09-25 17:31:56,200 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBLookupMediator Processing the first row returned : select id from
> transaction_uuid where uuid = ?
> 2008-09-25 17:31:56,200 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBLookupMediator Column : 1 returned value : 6004 Setting this as the
> message property : transaction_id
> 2008-09-25 17:31:56,201 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBLookupMediator End : DBLookup mediator
> 2008-09-25 17:31:56,201 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBReportMediator Start : DBReport mediator
> 2008-09-25 17:31:56,201 [127.0.0.1-vloeki_v01] [HttpServerWorker-5] DEBUG
> DBReportMediator Getting a connection from DataSource
> jdbc:mysql://localhost:3306/esb and preparing statement : delete from
> transaction_uuid where id = ?
> ...
> Here it hangs.. I can get more debug prints out of it by pressing
> Configuration -> save   but _no_ messages are processed.
> When the ESB hangs, Mysql is still up & running fine, I can happily view the
> database with mysql querybrowser, make new connections etc.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message