synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] Updated: (SYNAPSE-452) low load: ERROR ClientHandler Unexpected HTTP protocol error: Request already submitted
Date Sat, 20 Sep 2008 21:05:44 GMT

     [ https://issues.apache.org/jira/browse/SYNAPSE-452?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andreas Veithen updated SYNAPSE-452:
------------------------------------

    Component/s: Transports

> low load: ERROR ClientHandler Unexpected HTTP protocol error: Request already submitted
> ---------------------------------------------------------------------------------------
>
>                 Key: SYNAPSE-452
>                 URL: https://issues.apache.org/jira/browse/SYNAPSE-452
>             Project: Synapse
>          Issue Type: Bug
>          Components: Transports
>    Affects Versions: 1.2
>         Environment: found on wso2-esb 1.7.1 (having synapse 1.2) running on debian.
 XEN vm's running on Intel HW.
> The back-end is a spring webapp (using cxf, using commons-httpclient)
> We run the backend on the same VM as the ESB.
>            Reporter: harm verhagen
>
> I'm seen http connection related exceptions when under _very_ low load.
> what do I do:
> I proxy a soap interface of a backend, using wso2.
> I issue a soap command using www.soapui.org.
> After 1,2,3 commands (issue manually) the bus gives internal excpetions.
> what do I get:
> from ESB logging.
> 2008-09-16 15:33:29,157 [127.0.0.1-vloeki_v01] [HttpServerWorker-9] ERROR
> ClientHandler Unexpected HTTP protocol error: Request already submitted
> org.apache.http.HttpException: Request already submitted
>       at
> org.apache.http.impl.nio.DefaultNHttpClientConnection.submitRequest(DefaultNHttpClientConnection.java:203)
> reference:
> more details & logs at:
> http://wso2.org/mailarchive/esb-java-user/2008-September/000812.html 
> workaround:
> When not running the ESB and the backend on the same machine, (or better said, when routing
the traffic between ESB and backend trough an other machine). The problem went away..
> see http://wso2.org/mailarchive/esb-java-user/2008-September/000840.html.
> This obviously isn't a real fix.
> This issue might be related to:
> https://issues.apache.org/jira/browse/SYNAPSE-344
> https://issues.apache.org/jira/browse/SYNAPSE-341
> https://issues.apache.org/jira/browse/HTTPCORE-170
> however, I'm seeing this under very low loads, very reproducable. (I _never_ can more
that 3 commands in 4 seconds without getting this error)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message