synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Asankha C. Perera" <asan...@wso2.com>
Subject Re: Cleaning up dependencies
Date Thu, 08 May 2008 09:19:43 GMT

> my feeling is that we should not ship QuickFixJ and Qpid jars and we 
> can keep those two transports commented on the axis2.xml, and we must 
> add sections on this to the Sample Setup Guide. So when people need to 
> run these samples we can ask them to put these jars.
>
> Otherwise simple mediation case also carries all these jar files which 
> increases the synapse distribution size.
+1.. unless there are any other views, lets remove these from the core 
build of Synapse

Synapse 1.2 no longer needs
-------------------------------------------------
sandesha2-core-1.3.jar (previous RM implementation)
sandesha2-policy-1.3.jar (previous RM implementation)


New additions for Synapse 1.2
---------------------------------------------------
tribes-6.0.14.jar (axis2-clustering)
juli-6.0.14.jar (axis2-clustering)
mex-1.4-impl.jar (rampart-policy)

xmlParserAPIs-2.6.0.jar (axis2-kernel)
geronimo-stax-api_1.0_spec-1.0.1.jar (axis2-kernel)
woden-impl-dom-1.0M8.jar (axis2-kernel)

mercury-core-0.9.jar (new RM implementation)

spring-xml-1.0.3.jar (Synapse transformations)
commons-io-1.4.jar (Synapse transports)


To be removed from binary distribution
------------------------------------------------------------------
mina-core-1.1.0.jar (QuickFix)
quickfixj-core-1.3.1.jar (QuickFix)
quickfixj-msg-fix40-1.3.1.jar (QuickFix)
quickfixj-msg-fix41-1.3.1.jar (QuickFix)
quickfixj-msg-fix42-1.3.1.jar (QuickFix)
quickfixj-msg-fix43-1.3.1.jar (QuickFix)
quickfixj-msg-fix44-1.3.1.jar (QuickFix)
slf4j-api-1.3.0.jar (QuickFix)
slf4j-jdk14-1.3.0.jar (QuickFix)

mina-filter-ssl-1.0.0.jar (QPid)
qpid-client-1.0-incubating-M3-615355.jar (QPid)
qpid-common-1.0-incubating-M3-615355.jar (QPid)
commons-cli-1.0.jar (QPid)
geronimo-jms_1.1_spec-1.0.jar (QPid)
geronimo-jms_1.1_spec-1.1.jar  (QPid)

Already removed from 1.2 build as we do not depend on these
---------------------------------------------------------------------------------------------------------
xmlbeans-2.3.0.jar (rampart-policy)
geronimo-activation_1.1_spec-1.0.1.jar (axis2-kernel)
geronimo-javamail_1.4_spec-1.2.jar (axis2-kernel)


--- TODO : Verify if this addition is really needed---
commons-lang-2.1.jar (Maven site plugin?!)

asankha

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message