superset-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [incubator-superset] hyunjong-lee edited a comment on pull request #10765: Change pyarrow version for docker-compose up
Date Wed, 02 Sep 2020 14:33:59 GMT

hyunjong-lee edited a comment on pull request #10765:
URL: https://github.com/apache/incubator-superset/pull/10765#issuecomment-685775893


   @craig-rueda 
   
   - Yeah, I understand. The following is the logs when I execute `docker-compose up` with
`master` branch.
   
   ```sh
   superset_init            |
   superset_init            | ######################################################################
   superset_init            |
   superset_init            |
   superset_init            | Init Step 1/4 [Starting] -- Setting up admin user ( admin /
admin )
   superset_init            |
   superset_init            |
   superset_init            | ######################################################################
   superset_init            |
   superset_db              | 2020-09-02 14:30:02.355 UTC [25] LOG:  database system was shut
down at 2020-09-02 13:16:32 UTC
   superset_db              | 2020-09-02 14:30:02.381 UTC [1] LOG:  database system is ready
to accept connections
   superset_cache           | 1:M 02 Sep 14:30:02.069 * DB loaded from disk: 0.001 seconds
   superset_cache           | 1:M 02 Sep 14:30:02.069 * The server is now ready to accept
connections on port 6379
   superset_init            | Traceback (most recent call last):
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 583, in _build_master
   superset_init            |     ws.require(__requires__)
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 900, in require
   superset_init            |     needed = self.resolve(parse_requirements(requirements))
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 791, in resolve
   superset_init            |     raise VersionConflict(dist, req).with_context(dependent_req)
   superset_init            | pkg_resources.ContextualVersionConflict: (pyarrow 1.0.1 (/usr/local/lib/python3.6/site-packages),
Requirement.parse('pyarrow<0.18,>=0.17.0'), {'apache-superset'})
   superset_init            |
   superset_init            | During handling of the above exception, another exception occurred:
   superset_init            |
   superset_init            | Traceback (most recent call last):
   superset_init            |   File "/usr/local/bin/superset", line 6, in <module>
   superset_init            |     from pkg_resources import load_entry_point
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 3251, in <module>
   superset_init            |     @_call_aside
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 3235, in _call_aside
   superset_init            |     f(*args, **kwargs)
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 3264, in _initialize_master_working_set
   superset_init            |     working_set = WorkingSet._build_master()
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 585, in _build_master
   superset_init            |     return cls._build_from_requirements(__requires__)
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 598, in _build_from_requirements
   superset_init            |     dists = ws.resolve(reqs, Environment())
   superset_init            |   File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py",
line 786, in resolve
   superset_init            |     raise DistributionNotFound(req, requirers)
   superset_init            | pkg_resources.DistributionNotFound: The 'pyarrow<0.18,>=0.17.0'
distribution was not found and is required by apache-superset
   superset_init exited with code 1
   ```
   
   - The following block shows `pyarrow` version error.
   
   ```sh
   superset_init            | pkg_resources.ContextualVersionConflict: (pyarrow 1.0.1 (/usr/local/lib/python3.6/site-packages),
Requirement.parse('pyarrow<0.18,>=0.17.0'), {'apache-superset'})
   ```
   
   ![image](https://user-images.githubusercontent.com/391920/91996778-579b3480-ed74-11ea-9083-f15465137ff1.png)
   


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: notifications-unsubscribe@superset.apache.org
For additional commands, e-mail: notifications-help@superset.apache.org


Mime
View raw message