superset-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [incubator-superset] hc128168 opened a new issue #9759: upgrade pyarrow dependency to 0.17
Date Thu, 07 May 2020 02:51:26 GMT

hc128168 opened a new issue #9759:
URL: https://github.com/apache/incubator-superset/issues/9759


   **Is your feature request related to a problem? Please describe.**
   A clear and concise description of what the problem is. Ex. I'm always frustrated when
[...]
   
   **Describe the solution you'd like**
   A clear and concise description of what you want to happen.
   
   **Describe alternatives you've considered**
   A clear and concise description of any alternative solutions or features you've considered.
   
   **Additional context**
   Add any other context or screenshots about the feature request here.
   I used to have pyarrow 0.17 (the latest) on my machine.  When I installed the latest superset,
it downgraded it to 0.17.
   
   Then, I have to manually upgrade again but it complains that superset 0.36 is incompatible
with 0.17:
   ```
   $ pip3.6 install --user --upgrade pyarrow
   WARNING: pip is being invoked by an old script wrapper. This will fail in a future version
of pip.
   Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying
issue.
   To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
   Collecting pyarrow
     Downloading pyarrow-0.17.0-cp36-cp36m-manylinux2014_x86_64.whl (63.8 MB)
        |████████████████████████████████|
63.8 MB 10.5 MB/s 
   Requirement already satisfied, skipping upgrade: numpy>=1.14 in /home/hc/.local/lib/python3.6/site-packages
(from pyarrow) (1.18.4)
   Could not build wheels for numpy, since package 'wheel' is not installed.
   ERROR: apache-superset 0.36.0 has requirement pyarrow<0.17.0,>=0.16.0, but you'll
have pyarrow 0.17.0 which is incompatible.
   
   ```
   
   There is a bug in an older version of cython that pyarrow 0.16 uses.  Hence, it would be
great if superset could change the dependency of pyarrow to 0.17.
   
   Thanks!


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: notifications-unsubscribe@superset.apache.org
For additional commands, e-mail: notifications-help@superset.apache.org


Mime
View raw message