superset-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [incubator-superset] cgivre commented on issue #8151: Can't load plugin: sqlalchemy.dialects:drill.jdbc
Date Sun, 01 Sep 2019 15:25:52 GMT
cgivre commented on issue #8151:  Can't load plugin: sqlalchemy.dialects:drill.jdbc
URL: https://github.com/apache/incubator-superset/issues/8151#issuecomment-526928156
 
 
   @zachary124 
   To use Drill with JDBC with Superset you have to use our sqlalchemy dialect which is available
here:https://github.com/cgivre/sqlalchemy-drill/tree/jdbc_support
   
   So, I've pushed a branch that has JDBC support, however this is a WIP.  It works, however,
@JohnOmernik and I are trying to figure out how to best handle downloading, installing and
configuring the JDBC driver as a part of the install process.  
   
   The code on the repo works but at the moment, it has hard-coded paths to the JDBC driver.
 You can see how to configure it here: https://github.com/cgivre/sqlalchemy-drill/blob/jdbc_support/test/test_jdbc.py
   
   I'll try to fix it up tonight and remove the hard coded links.
   
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

---------------------------------------------------------------------
To unsubscribe, e-mail: notifications-unsubscribe@superset.apache.org
For additional commands, e-mail: notifications-help@superset.apache.org


Mime
View raw message