superset-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [incubator-superset] KilimAnnejaro commented on issue #7514: AttributeError on superset db upgrade
Date Thu, 16 May 2019 15:36:13 GMT
KilimAnnejaro commented on issue #7514: AttributeError on superset db upgrade
URL: https://github.com/apache/incubator-superset/issues/7514#issuecomment-493118936
 
 
   I tried that and got this error: sqlalchemy.exc.InvalidRequestError: Can't determine which
FROM clause to join from, there are multiple FROMS which can join to this entity. Try adding
an explicit ON clause to help resolve the ambiguity.
   
   So I used the fix from https://github.com/apache/incubator-superset/issues/6977 and got
the new error "ModuleNotFoundError: No module named 'sqlalchemy'". Which feels really strange
to me, since when I run `pip freeze` I get this output:
   
   alembic==1.0.10
   amqp==2.4.2
   apispec==1.3.2
   asn1crypto==0.24.0
   attrs==19.1.0
   Babel==2.6.0
   billiard==3.6.0.0
   bleach==3.1.0
   boto3==1.4.7
   botocore==1.7.48
   cchardet==2.1.4
   celery==4.3.0
   certifi==2019.3.9
   cffi==1.12.3
   chardet==3.0.4
   click==6.7
   colorama==0.3.9
   conda==4.6.14
   contextlib2==0.5.5
   croniter==0.3.30
   cryptography==2.6.1
   decorator==4.4.0
   defusedxml==0.6.0
   docutils==0.14
   et-xmlfile==1.0.1
   Flask==0.12.4
   Flask-AppBuilder==2.0.0
   Flask-Babel==0.12.2
   Flask-Caching==1.7.1
   Flask-Compress==1.4.0
   Flask-JWT-Extended==3.18.1
   Flask-Login==0.4.1
   Flask-Migrate==2.4.0
   Flask-OpenID==1.2.5
   Flask-SQLAlchemy==2.4.0
   Flask-WTF==0.14.2
   flower==0.9.3
   future==0.16.0
   geographiclib==1.49
   geopy==1.19.0
   gunicorn==19.9.0
   humanize==0.5.1
   idna==2.8
   ijson==2.3
   isodate==0.6.0
   itsdangerous==1.1.0
   jdcal==1.4.1
   Jinja2==2.10.1
   jmespath==0.9.4
   jsonlines==1.2.0
   jsonschema==3.0.1
   kombu==4.5.0
   linear-tsv==1.1.0
   Mako==1.0.9
   Markdown==3.1
   MarkupSafe==1.1.1
   marshmallow==2.19.2
   marshmallow-enum==1.4.1
   marshmallow-sqlalchemy==0.16.2
   mkl-fft==1.0.12
   mkl-random==1.0.2
   numpy==1.16.3
   openpyxl==2.4.11
   pandas==0.24.2
   parsedatetime==2.4
   pathlib2==2.3.3
   polyline==1.3.2
   prison==0.1.0
   psycopg2==2.7.7
   py==1.8.0
   pycosat==0.6.3
   pycparser==2.19
   pydruid==0.5.2
   PyHive==0.6.1
   PyJWT==1.7.1
   pyOpenSSL==19.0.0
   pyrsistent==0.15.1
   PySocks==1.6.8
   python-dateutil==2.8.0
   python-editor==1.0.4
   python-geohash==0.8.5
   python3-openid==3.1.0
   pytz==2019.1
   PyYAML==5.1
   requests==2.21.0
   retry==0.9.2
   rfc3986==1.3.1
   ruamel-yaml==0.15.46
   s3transfer==0.1.13
   sasl==0.2.1
   selenium==3.141.0
   simplejson==3.16.0
   six==1.12.0
   **SQLAlchemy==1.3.2**
   SQLAlchemy-Utils==0.33.11
   sqlparse==0.3.0
   superset==0.28.1
   tableschema==1.4.1
   tabulator==1.20.0
   thrift==0.11.0
   thrift-sasl==0.3.0
   tornado==5.1.1
   unicodecsv==0.14.1
   Unidecode==1.0.23
   urllib3==1.24.3
   vine==1.3.0
   webencodings==0.5.1
   Werkzeug==0.15.2
   WTForms==2.2.1
   WTForms-JSON==0.3.3
   xlrd==1.2.0
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

---------------------------------------------------------------------
To unsubscribe, e-mail: notifications-unsubscribe@superset.apache.org
For additional commands, e-mail: notifications-help@superset.apache.org


Mime
View raw message