superset-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From johnbod...@apache.org
Subject [incubator-superset] branch master updated: Update index.rst (#7672)
Date Tue, 11 Jun 2019 16:46:46 GMT
This is an automated email from the ASF dual-hosted git repository.

johnbodley pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/incubator-superset.git


The following commit(s) were added to refs/heads/master by this push:
     new 541db94  Update index.rst (#7672)
541db94 is described below

commit 541db9413314321d73d37c756aaddaf711ad65fa
Author: John Bodley <4567245+john-bodley@users.noreply.github.com>
AuthorDate: Tue Jun 11 09:46:27 2019 -0700

    Update index.rst (#7672)
---
 README.md             |  25 +-----------
 docs/index.rst        |  33 ++++++++++++++-
 docs/installation.rst | 110 +++++++++++++++++++++++++-------------------------
 3 files changed, 90 insertions(+), 78 deletions(-)

diff --git a/README.md b/README.md
index 47ac542..0931f45 100644
--- a/README.md
+++ b/README.md
@@ -94,29 +94,8 @@ Superset speaks many SQL dialects through SQLAlchemy, a Python
 ORM that is compatible with
 [most common databases](https://docs.sqlalchemy.org/en/rel_1_2/core/engines.html).
 
-Superset can be used to visualize data out of most databases:
-* MySQL
-* Postgres
-* Vertica
-* Oracle
-* Microsoft SQL Server
-* SQLite
-* Greenplum
-* Firebird
-* MariaDB
-* Sybase
-* IBM DB2
-* Exasol
-* MonetDB
-* Snowflake
-* Redshift
-* Clickhouse
-* Apache Kylin
-* Apache Drill
-* Google BigQuery
-* **more!** look for the availability of a SQLAlchemy dialect for your database
-  to find out whether it will work with Superset
-
+A list of currently supported SQL databases can be found
+[here](https://superset.incubator.apache.org/#databases).
 
 Apache Druid (Incubating)!
 ------
diff --git a/docs/index.rst b/docs/index.rst
index 926031f..00b796d 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -93,6 +93,38 @@ Features
 - Integration with most SQL-speaking RDBMS through SQLAlchemy
 - Deep integration with Druid.io
 
+Databases
+---------
+
+The following RDBMS are currently suppored:
+
+- `Amazon Athena <https://aws.amazon.com/athena/>`_
+- `Amazon Redshift <https://aws.amazon.com/redshift/>`_
+- `Apache Drill <https://drill.apache.org/>`_
+- `Apache Druid <http://druid.io/>`_
+- `Apache Hive <https://hive.apache.org/>`_
+- `Apache Impala <https://impala.apache.org/>`_
+- `Apache Kylin <http://kylin.apache.org/>`_
+- `Apache Pinot <https://pinot.incubator.apache.org/>`_
+- `Apache Spark SQL <https://spark.apache.org/sql/>`_
+- `BigQuery <https://cloud.google.com/bigquery/>`_
+- `ClickHouse <https://clickhouse.yandex/>`_
+- `Google Sheets <https://www.google.com/sheets/about/>`_
+- `Greenplum <https://greenplum.org/>`_
+- `IBM Db2 <https://www.ibm.com/analytics/db2/>`_
+- `MySQL <https://www.mysql.com/>`_
+- `Oracle <https://www.oracle.com/database/>`_
+- `PostgreSQL <https://www.postgresql.org/>`_
+- `Presto <http://prestodb.github.io/>`_
+- `Snowflake <https://www.snowflake.com/>`_
+- `SQLite <https://www.sqlite.org/>`_
+- `SQL Server <https://www.microsoft.com/en-us/sql-server/>`_
+- `Teradata <https://www.teradata.com/>`_
+- `Vertica <https://www.vertica.com/>`_
+
+Other database engines with a proper DB-API driver and SQLAlchemy dialect should
+be supported as well.
+
 Screenshots
 -----------
 
@@ -135,4 +167,3 @@ Indices and tables
 * :ref:`genindex`
 * :ref:`modindex`
 * :ref:`search`
-
diff --git a/docs/installation.rst b/docs/installation.rst
index 221d111..f31c34b 100644
--- a/docs/installation.rst
+++ b/docs/installation.rst
@@ -123,7 +123,7 @@ that the required dependencies are installed: ::
     sudo yum upgrade python-setuptools
     sudo yum install gcc gcc-c++ libffi-devel python-devel python-pip python-wheel openssl-devel
libsasl2-devel openldap-devel
 
-**Mac OS X** If possible, you should upgrade to the latest version of OS X as issues are
more likely to be resolved for that version. 
+**Mac OS X** If possible, you should upgrade to the latest version of OS X as issues are
more likely to be resolved for that version.
 You *will likely need* the latest version of XCode available for your installed version of
OS X. You should also install
 the XCode command line tools: ::
 
@@ -346,58 +346,60 @@ connect to the databases you want to access through Superset.
 
 Here's a list of some of the recommended packages.
 
-+---------------+-------------------------------------+-------------------------------------------------+
-| database      | pypi package                        | SQLAlchemy URI prefix           
               |
-+===============+=====================================+=================================================+
-|  MySQL        | ``pip install mysqlclient``         | ``mysql://``                    
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Postgres     | ``pip install psycopg2``            | ``postgresql+psycopg2://``      
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Presto       | ``pip install pyhive``              | ``presto://``                   
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Hive         | ``pip install pyhive``              | ``hive://``                     
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Oracle       | ``pip install cx_Oracle``           | ``oracle://``                   
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  sqlite       |                                     | ``sqlite://``                   
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Snowflake    | ``pip install snowflake-sqlalchemy``| ``snowflake://``                
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Redshift     | ``pip install sqlalchemy-redshift`` | ``redshift+psycopg2://``        
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  MSSQL        | ``pip install pymssql``             | ``mssql://``                    
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Impala       | ``pip install impyla``              | ``impala://``                   
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  SparkSQL     | ``pip install pyhive``              | ``jdbc+hive://``                
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Greenplum    | ``pip install psycopg2``            | ``postgresql+psycopg2://``      
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Athena       | ``pip install "PyAthenaJDBC>1.0.9"``| ``awsathena+jdbc://``        
                  |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Athena       | ``pip install "PyAthena>1.2.0"``    | ``awsathena+rest://``        
                  |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Vertica      | ``pip install                       |  ``vertica+vertica_python://``  
               |
-|               | sqlalchemy-vertica-python``         |                                 
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  ClickHouse   | ``pip install                       | ``clickhouse://``               
               |
-|               | sqlalchemy-clickhouse``             |                                 
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Kylin        | ``pip install kylinpy``             | ``kylin://``                    
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  BigQuery     | ``pip install pybigquery``          | ``bigquery://``                 
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Teradata     | ``pip install sqlalchemy-teradata`` | ``teradata://``                 
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Pinot        | ``pip install pinotdb``             | ``pinot+http://controller:5436/``
              |
-|               |                                     | ``query?server=http://controller:5983/``
       |
-+---------------+-------------------------------------+-------------------------------------------------+
-|  Apache Drill |                                     | For the REST API:``             
               |
-|               |                                     | ``drill+sadrill://``            
               |
-|               |                                     | For JDBC                        
               |
-|               |                                     | ``drill+jdbc://``               
               |
-+---------------+-------------------------------------+-------------------------------------------------+
-
++------------------+---------------------------------------+-------------------------------------------------+
+| database         | pypi package                          | SQLAlchemy URI prefix      
                    |
++==================+=======================================+=================================================+
+| Amazon Athena    | ``pip install "PyAthenaJDBC>1.0.9"``  | ``awsathena+jdbc://``   
                       |
++------------------+---------------------------------------+-------------------------------------------------+
+| Amazon Athena    | ``pip install "PyAthena>1.2.0"``      | ``awsathena+rest://``   
                       |
++------------------+---------------------------------------+-------------------------------------------------+
+| Amazon Redshift  | ``pip install sqlalchemy-redshift``   | ``redshift+psycopg2://``   
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Apache Drill     | ``pip install sqlalchemy-drill``      | For the REST API:``        
                    |
+|                  |                                       | ``drill+sadrill://``       
                    |
+|                  |                                       | For JDBC                   
                    |
+|                  |                                       | ``drill+jdbc://``          
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Apache Druid     | ``pip install pyduid``                | ``druid://``               
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Apache Hive      | ``pip install pyhive``                | ``hive://``                
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Apache Impala    | ``pip install impyla``                | ``impala://``              
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Apache Kylin     | ``pip install kylinpy``               | ``kylin://``               
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Apache Pinot     | ``pip install pinotdb``               | ``pinot+http://CONTROLLER:5436/``
              |
+|                  |                                       | ``query?server=http://CONTROLLER:5983/``
       |
++------------------+---------------------------------------+-------------------------------------------------+
+| Apache Spark SQL | ``pip install pyhive``                | ``jdbc+hive://``           
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| BigQuery         | ``pip install pybigquery``            | ``bigquery://``            
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| ClickHouse       | ``pip install sqlalchemy-clickhouse`` |                            
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Google Sheets    | ``pip install gsheetsdb``             | ``gsheets://`              
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| IBM Db2          | ``pip install ibm_db_sa``             | ``db2+ibm_db://``          
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| MySQL            | ``pip install mysqlclient``           | ``mysql://``               
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Oracle           | ``pip install cx_Oracle``             | ``oracle://``              
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| PostgreSQL       | ``pip install psycopg2``              | ``postgresql+psycopg2://`` 
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Presto           | ``pip install pyhive``                | ``presto://``              
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Snowflake        | ``pip install snowflake-sqlalchemy``  | ``snowflake://``           
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| SQLite           |                                       | ``sqlite://``              
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| SQL Server       | ``pip install pymssql``               | ``mssql://``               
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Teradata         | ``pip install sqlalchemy-teradata``   | ``teradata://``            
                    |
++------------------+---------------------------------------+-------------------------------------------------+
+| Vertica          | ``pip install                         |  ``vertica+vertica_python://``
                 |
+|                  | sqlalchemy-vertica-python``           |                            
                    |
++------------------+---------------------------------------+-------------------------------------------------+
 
 Note that many other databases are supported, the main criteria being the
 existence of a functional SqlAlchemy dialect and Python driver. Googling
@@ -948,7 +950,7 @@ To allow scheduled queries, add the following to your `config.py`:
     }
 
 This feature flag is based on [react-jsonschema-form](https://github.com/mozilla-services/react-jsonschema-form),
-and will add a button called "Schedule Query" to SQL Lab. When the button is 
+and will add a button called "Schedule Query" to SQL Lab. When the button is
 clicked, a modal will show up where the user can add the metadata required for
 scheduling the query.
 


Mime
View raw message