superset-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From maximebeauche...@apache.org
Subject [incubator-superset] branch master updated: [docs] improve UPDATING.md around 0.31's [now] optional deps (#7117)
Date Mon, 25 Mar 2019 22:03:17 GMT
This is an automated email from the ASF dual-hosted git repository.

maximebeauchemin pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/incubator-superset.git


The following commit(s) were added to refs/heads/master by this push:
     new 87fae5c  [docs] improve UPDATING.md around 0.31's [now] optional deps (#7117)
87fae5c is described below

commit 87fae5c602cbb2b74eaaa4df27b46204ced4d0ab
Author: Maxime Beauchemin <maximebeauchemin@gmail.com>
AuthorDate: Mon Mar 25 15:03:08 2019 -0700

    [docs] improve UPDATING.md around 0.31's [now] optional deps (#7117)
---
 UPDATING.md | 15 +++++++++++----
 1 file changed, 11 insertions(+), 4 deletions(-)

diff --git a/UPDATING.md b/UPDATING.md
index 5c7edbe..27ea571 100644
--- a/UPDATING.md
+++ b/UPDATING.md
@@ -22,10 +22,6 @@ This file documents any backwards-incompatible changes in Superset and
 assists people when migrating to a new version.
 
 ## Superset 0.32.0
-* If you use `Hive` or `Presto`, we've moved some dependencies that were
-  in the main package as optional now. To get these packages,
-  run `pip install superset[presto]` and/or `pip install superset[hive]` as
-  required.
 
 * [5445](https://github.com/apache/incubator-superset/pull/5445) : a change 
 which prevents encoding of empty string from form data in the datanbase. 
@@ -33,6 +29,17 @@ This involves a non-schema changing migration which does potentially impact
 a large number of records. Scheduled downtime may be advised.
 
 ## Superset 0.31.0
+
+* If you use `Hive` or `Presto`, we've moved some dependencies that were
+  in the main package as optional now. To get these packages,
+  run `pip install superset[presto]` and/or `pip install superset[hive]` as
+  required.
+
+* Similarly, if you use Celery's `flower`, `gsheetsdb`, `thrift` or
+  `thrift-sasl`, those dependencies have now been made optional in our
+  package, meaning you may have to install them in your environment post
+  0.31.0
+
 * boto3 / botocore was removed from the dependency list. If you use s3
 as a place to store your SQL Lab result set or Hive uploads, you may
 have to rely on an alternate requirements.txt file to install those


Mime
View raw message