superset-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From maximebeauche...@apache.org
Subject [incubator-superset] branch master updated: Fix: updated required cryptography version to 2.4.2 to resolve #6509 (#6516)
Date Thu, 27 Dec 2018 22:14:06 GMT
This is an automated email from the ASF dual-hosted git repository.

maximebeauchemin pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/incubator-superset.git


The following commit(s) were added to refs/heads/master by this push:
     new d99b36e  Fix: updated required cryptography version to 2.4.2 to resolve #6509 (#6516)
d99b36e is described below

commit d99b36e892687c061ac517c7cca3d6af6cf6fbf8
Author: Patrick Tyler Haas <patrick.tyler.haas@gmail.com>
AuthorDate: Thu Dec 27 14:14:01 2018 -0800

    Fix: updated required cryptography version to 2.4.2 to resolve #6509 (#6516)
    
    * Fix: updated required cryptography version to 2.4.2 to resolve #6509
    
    * Fix: updated cryptography version to 2.4.2 to resolve #6509
    
    * Fix: updated cryptography version to 2.4.2 to resolve #6509
    
    * Revert "Fix: updated required cryptography version to 2.4.2 to resolve #6509"
    
    This reverts commit b57b08c8e578d814ac0c6a696afe9ee34ef1e70a.
    
    * Fix: updated cryptography version to 2.4.2
---
 requirements.txt | 2 +-
 setup.py         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/requirements.txt b/requirements.txt
index 0b3c67b..7bef543 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -20,7 +20,7 @@ click==6.7
 colorama==0.3.9
 contextlib2==0.5.5
 croniter==0.3.25
-cryptography==1.9
+cryptography==2.4.2
 decorator==4.3.0          # via retry
 defusedxml==0.5.0         # via python3-openid
 et-xmlfile==1.0.1         # via openpyxl
diff --git a/setup.py b/setup.py
index 53804ad..c0f2b20 100644
--- a/setup.py
+++ b/setup.py
@@ -58,7 +58,7 @@ setup(
         'click>=6.0, <7.0.0',  # click >=7 forces "-" instead of "_"
         'colorama',
         'contextlib2',
-        'cryptography',
+        'cryptography>=2.4.2',
         'flask>=1.0.0, <2.0.0',
         'flask-appbuilder>=1.12.1, <2.0.0',
         'flask-caching',


Mime
View raw message