superset-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From maximebeauche...@apache.org
Subject [incubator-superset] branch master updated: Update the installation document based on Python 3.6+ (#6370)
Date Thu, 15 Nov 2018 02:14:17 GMT
This is an automated email from the ASF dual-hosted git repository.

maximebeauchemin pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/incubator-superset.git


The following commit(s) were added to refs/heads/master by this push:
     new a5b528c  Update the installation document based on Python 3.6+ (#6370)
a5b528c is described below

commit a5b528c68890eb0090d97c4920725dcfa3d93d8a
Author: Kengo Seki <sekikn@apache.org>
AuthorDate: Wed Nov 14 18:14:11 2018 -0800

    Update the installation document based on Python 3.6+ (#6370)
    
    * Update the description based on Ubuntu 16.04 with 18.04,
      since Python version bundled with the former is 3.5,
      which is not already supported
    
    * Remove obsolete descriptions based on Python <= 3.5
---
 docs/installation.rst | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)

diff --git a/docs/installation.rst b/docs/installation.rst
index 75f6d25..d5c63c4 100644
--- a/docs/installation.rst
+++ b/docs/installation.rst
@@ -78,9 +78,9 @@ the required dependencies are installed: ::
 
     sudo apt-get install build-essential libssl-dev libffi-dev python-dev python-pip libsasl2-dev
libldap2-dev
 
-**Ubuntu 16.04** If you have python3.5 installed alongside with python2.7, as is default
on **Ubuntu 16.04 LTS**, run this command also: ::
+**Ubuntu 18.04** If you have python3.6 installed alongside with python2.7, as is default
on **Ubuntu 18.04 LTS**, run this command also: ::
 
-    sudo apt-get install build-essential libssl-dev libffi-dev python3.5-dev python-pip libsasl2-dev
libldap2-dev
+    sudo apt-get install build-essential libssl-dev libffi-dev python3.6-dev python-pip libsasl2-dev
libldap2-dev
 
 otherwise build for ``cryptography`` fails.
 
@@ -105,17 +105,18 @@ attempt it, download `get-pip.py <https://bootstrap.pypa.io/get-pip.py>`_,
and r
 
 Python virtualenv
 -----------------
-It is recommended to install Superset inside a virtualenv. Python 3 already ships virtualenv,
for
-Python 2 you need to install it. If it's packaged for your operating systems install it from
there
-otherwise you can install from pip: ::
+It is recommended to install Superset inside a virtualenv. Python 3 already ships virtualenv.
+But if it's not installed in your environment for some reason, you can install it
+via the package for your operating systems, otherwise you can install from pip: ::
 
     pip install virtualenv
 
 You can create and activate a virtualenv by: ::
 
-    # virtualenv is shipped in Python 3 as pyvenv
-    virtualenv venv
-    . ./venv/bin/activate
+    # virtualenv is shipped in Python 3.6+ as venv instead of pyvenv.
+    # See https://docs.python.org/3.6/library/venv.html
+    python3 -m venv venv
+    . venv/bin/activate
 
 On windows the syntax for activating it is a bit different: ::
 


Mime
View raw message