subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitin Bhide <nitinbh...@gmail.com>
Subject corrupted svn repository with “serialized hash missing terminator” error
Date Sun, 01 Sep 2013 06:32:18 GMT
I have a local subversion repository. I am trying to convert it to
Mercurial. In the process I discovered that repository is corrupted. I have
tried the following

1. svnadmin verify - confirmed that repository is corrupted at revision
1265. The verify stops at this revision.
2. svnadmin recover - was unable to recover the repository.
3.  tried to dump the repository content. svnadmin dump fails at revision
1265. So dumped till 1264. Took another dump from revision 1322. (all
revision from 1265 to 1321 are giving the serialized hash terminator error).
4. I tried to combine the dumps and load it into a new repository. However,
some files were added in the 'missing' revisions (1265 to 1321) and while
loading dump I am getting errors.

I googled for error and advice seems to be dump the repository and reload
the contents in new repository. However, that does not work for me.

I tried to find what exactly is the meaning of the error. However, I could
not get any information. I tried to read the documentation of FSFS
structure (
http://svn.apache.org/repos/asf/subversion/trunk/subversion/libsvn_fs_fs/structure).
I tried to manually check revision file for 1265 and see what is wrong. But
could not find anything visibly wrong.

Is there any way to correct this error in the repository
(manually/programmatically) ?

If someone can give me a hint on what is wrong in the file and underwhat
conditions this error occurs, I will try to write a script to correct it.

Regards,
Nitin

Mime
View raw message