subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Lasnier <guillaume.lasn...@hybris.com>
Subject Re: Proxy error on SVN 1.8.1
Date Wed, 31 Jul 2013 09:30:30 GMT
Hi Lieven,
Please find attached the tcpdump that dumps traffic between my laptop and
the proxy. The only information I could get about the proxy is that it's
an ISA server.

Regards

--
Guillaume Lasnier 



On 7/29/13 7:01 PM, "Lieven Govaerts" <lgo@apache.org> wrote:

>Hi,
>
>On Mon, Jul 29, 2013 at 6:28 PM, Guillaume Lasnier
><guillaume.lasnier@hybris.com> wrote:
>> Hi all,
>> When issuing the following command, I get the following error:
>>
>> $ svn -v log
>> svn: E120107: Unable to connect to a repository at URL
>> 'https://svncvs.myhost.mydomain/repos/myrepo/trunk/hybris/bin/platform'
>> svn: E120107: Error running context: The proxy server returned an error
>> while setting up the SSL tunnel.
>
>That error indicates the proxy returned an error to the CONNECT
>request that svn uses to initiate the ssl tunnel.
>What proxy server do you use? KeepAlive off? Specific authentication?
>
>I think the easiest way to find out what's going on is to trace the
>network traffic. Can you make a trace with fiddler or wireshark?
>
>>
>> I am using subversion 1.8.1 on Mac OS X installed with homebrew.
>> I have configured the proxy the following way in ~/.subversion/servers :
>>
>> [groups]
>> # group1 = *.collab.net
>> # othergroup = repository.blarggitywhoomph.com
>> # thirdgroup = *.example.com
>> mygroup = *.myhost.mydomain
>>
>> # Information for my group:
>> [mygroup]
>> http-proxy-host = 192.168.xxx.xxx
>> http-proxy-port = 1234
>> http-proxy-username = john
>> http-proxy-password = doe
>>
>>
>> This configuration used to work with subversion 1.7.
>>
>Configuration looks ok, and if it has worked before then we should be
>able to make it work in 1.8.1 too.
>
>Lieven
>
>
>> Do have any idea?
>>
>> --
>>
>> Guillaume Lasnier
>>
>>
>>
>>

Mime
View raw message