subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BIRD Neil <Neil.B...@uk.thalesgroup.com>
Subject Python error in 1.8.1 test suite - authz_tests.py
Date Tue, 30 Jul 2013 14:47:17 GMT
  I'm trying to build 1.8.1 on Scientific Linux 6 (effectievly RHEL6).  All builds OK, but
the tests fail halfway through.  Running the failing test by itself:

$make check CLEANUP=true TESTS=subversion/tests/cmdline/authz_tests.py
[1/1] authz_tests.pymake: *** [check] Error 1


  tests.log contains:

START: authz_tests.py
Traceback (most recent call last):
  File "./build/run_tests.py", line 724, in <module>
    main()
  File "./build/run_tests.py", line 717, in main
    failed = th.run(args[2:])
  File "./build/run_tests.py", line 190, in run
    failed = self._run_test(prog, cnt, len(list)) or failed
  File "./build/run_tests.py", line 597, in _run_test
    failed = self._run_py_test(progabs, test_nums, dots_needed)
  File "./build/run_tests.py", line 535, in _run_py_test
    test_selection=test_selection)
  File "/home/nabird/usr/rpmbuild/BUILD/subversion-1.8.1/subversion/tests/cmdline/svntest/main.py",
line 2095, in execute_tests
    http_proxy=options.http_proxy)
  File "/home/nabird/usr/rpmbuild/BUILD/subversion-1.8.1/subversion/tests/cmdline/svntest/main.py",
line 595, in create_config_dir
    "http-proxy-port=%d" % (http_proxy_parsed.port or 80)
  File "/usr/lib/python2.6/urlparse.py", line 102, in port
    return int(port, 10)
ValueError: invalid literal for int() with base 10: ''


  I've not got a clue what's going on here;  I tried adding some debug but only made matters
worse (I'm no python guru :) )

  I do have http_proxy set (to something like "http_proxy://proxyhost:portno/"), but the above
error occurs nomatter whether it's set or not.


  Any pointers?

-- 
[neil@fnx ~]# rm -f .signature
[neil@fnx ~]# ls -l .signature
ls: .signature: No such file or directory
[neil@fnx ~]# exit

Mime
View raw message