subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Martin <philip.mar...@wandisco.com>
Subject Re: Possible bug: Bad record MAC
Date Tue, 05 Mar 2013 22:12:17 GMT
Paolo Cavallini <cavallini@faunalia.it> writes:

> Hi Philip,
> thanks for your reply.
>
> Il 05/03/2013 14:09, Philip Martin ha scritto:
>
>> You don't say which client/OS you are using or which http library
>> the Subversion client is using.
>
> subversion 1.6.17dfsg-4
> openssl 1.0.1e-1
> on debian testing, up to date.
> I tried downgrading openssl, the error remains the same.

Debian's Subversion uses GnuTLS rather than OpenSSL.  I suppose you
could build an older/newer GnuTLS and try that.  Or you could rebuild
Subversion and neon to use OpenSSL and see if that fixes the problem.
Or you could rebuild Subversion to use serf and use that instead of
neon.  Or perhaps the 3rd party Subversion binaries use OpenSSL and/or
have serf support.

> Network has bben checked cables and switch have been changed, firewall
> and proxy have not changed.
> So it could be a communication problem between openssl and subversion.
>
> Any hint on how to debug will be greatly appreciated.

Debugging SSL is hard.  I don't really know what to suggest.  Perhaps
build a debug version of GnuTLS and use gdb to stop at the point the
error is raised and examine the decoded data that is causing the
problem.

-- 
Certified & Supported Apache Subversion Downloads:
http://www.wandisco.com/subversion/download

Mime
View raw message