subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Masaru Kitajima <tachi.sil...@gmail.com>
Subject Re: Problem in connecting the server
Date Tue, 05 Jun 2012 09:42:46 GMT
I'm not sure if I have a connection problem. As "Yum" and "wget"
works well on the server. And I can connect to the server using
HTTP, FTP, and SSH.

And I'm not behind any proxies. Only one thing which is different
is that it's a VPS. But the VPS has a global IP address and I can
configure almost everything.

Ah, I'm really confusing. Is there any specific port I should open
using iptables for Subversion HTTP connection besides 80?

On 2012/06/05, at 18:26, Stefan Sperling wrote:
> On Tue, Jun 05, 2012 at 03:14:21PM +0900, Masaru Kitajima wrote:
>> Stefan,
>> 
>> I found another problem. This may be server side Subversion configuration
>> is somehow miss configured, I guess.
>> 
>> I installed subversion using "yum -y install subversion" and Subversion
>> 1.6.11 was installed. I also did "yum -y install mod_dav_svn" too.
>> 
>> Today, I found that Subversion 1.7.5 is released. So I tried to get it
>> and build it.
>> 
>> Connecting to my server using SSH and typed 
>> "svn co http://svn.apache.org/repos/asf/subversion/trunk subversion"
>> then again "svn: OPTIONS (URL: 'http://svn.apache.org/repos/asf/subversion/trunk'):

>> Could not read status line:" was shown on the server.
>> 
>> I have another server running CentOS6 and tried the same thing and
>> it succeeded. I could get the source code from apache.org's repository.
>> 
>> I'm really confused...
> 
> If you cannot even check out from svn.apache.org (which should virtually
> always work), maybe there is a connection problem?
> 
> Are you behind a HTTP proxy?
> Is something blocking or interfering with network traffic?


Mime
View raw message