subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kai Bernhard <bernh...@morgen-studios.com>
Subject Re: About Apache+SVN "Digest mutual authentication failure: request-digest mismatch" / Server was not authenticated correctly
Date Tue, 12 Jun 2012 15:16:57 GMT
The actual problem was an authentication failure (with the message mentioned in the subject
line: "Digest mutual authentication failure: request-digest mismatch") that occured sometimes,
as already mentioned most likely when merging. I thought that was clear enough from my previous
post, sorry.

Regarding the version information:

Server:
Apache 2.2.14
Subversion 1.6.6 (r40053)
apr 1.3.8
apr-utils 1.3.9
neon 0.29.0
OpenSSL 0.9.8k
zlib 1.2.3.3

The problem occurred with different clients and client versions, on Linux, Mac, and Windows.
I use commandline svn (1.6.17 - 1.7.4 on Ubuntu or Gentoo) or latest TortiseSVN:
TortoiseSVN 1.7.7, Build 22907 - 64 Bit , 2012/05/15 12:16:05
Subversion 1.7.5, 
apr 1.4.6
apr-utils 1.3.12
neon 0.29.6
OpenSSL 1.0.1c 10 May 2012
zlib 1.2.7


________________________________________
Von: Daniel Shahaf [d.s@daniel.shahaf.name]
Gesendet: Samstag, 9. Juni 2012 08:20
An: Kai Bernhard
Cc: users@subversion.apache.org
Betreff: Re: About Apache+SVN "Digest mutual authentication failure:    request-digest mismatch"
/ Server was not authenticated correctly

You neglected to mention what the actual problem you ran into is and
what versions of svn (and relevant dependencies) you use on your client
and server.

Thanks for the information!


Kai Bernhard wrote on Fri, Jun 08, 2012 at 15:05:34 +0200:
> Hello list,
>
> I was experiencing problems with authentication (using HTTP Digest Auth+SSL) on our SVN
server. It seems it has been reported a few years ago (see http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=911173),
but I was not able to find a solution anywhere. The problem occured most often when merging,
sometimes when checking out/in or updating. Trying to work around another problem (apache
leaking memory, see https://bugs.launchpad.net/ubuntu/+source/subversion/+bug/273859), I set
'SVNAllowBulkUpdates Off' which caused the authentication problem to occur a lot more frequently.
Finally it seems both my problems are gone after switching from mpm-worker to mpm-prefork,
with 'SVNAllowBulkUpdates Off'.
>
> This info might be useful for other users experiencing the same problem and give a hint
that the authentication problem seems to be related to threading issues.
>
> Cheers,
>
> Kai
>
> PS. I'm not subscribed to the list, please CC me in responses or mail me in case I can
help with more detailed info.

Mime
View raw message