subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Masaru Kitajima <tachi.sil...@gmail.com>
Subject Re: Problem in connecting the server
Date Tue, 05 Jun 2012 06:14:21 GMT
Stefan,

I found another problem. This may be server side Subversion configuration
is somehow miss configured, I guess.

I installed subversion using "yum -y install subversion" and Subversion
1.6.11 was installed. I also did "yum -y install mod_dav_svn" too.

Today, I found that Subversion 1.7.5 is released. So I tried to get it
and build it.

Connecting to my server using SSH and typed 
"svn co http://svn.apache.org/repos/asf/subversion/trunk subversion"
then again "svn: OPTIONS (URL: 'http://svn.apache.org/repos/asf/subversion/trunk'): 
Could not read status line:" was shown on the server.

I have another server running CentOS6 and tried the same thing and
it succeeded. I could get the source code from apache.org's repository.

I'm really confused...

On 2012/06/04, at 19:36, Stefan Sperling wrote:
> On Mon, Jun 04, 2012 at 10:02:02AM +0900, Masaru Kitajima wrote:
>> And in the /etc/httpd/conf/httpd/conf, the WebDAV is defined as below.
>> <IfModule mod_dav_fs.c>
>>    # Location of the WebDAV lock database.
>>    DAVLockDB /var/lib/svn/dav.lock
>> </IfModule>
>> <Directory /var/lib/svn>
>>    DAV on
>> </Directory>
> 
> Why did you add the above? I don't think it's necessary. It might even
> conflict with Subversion's own DAV handler. Setting SVNAutoversioning on
> as you did below should be enough to allow DAV clients to connect to
> Subversion. Try removing the above lines from your configuration and
> maybe that will fix the problem.
> 
>> 
>> And in /etc/httpd/conf.d/subversion.conf. I defined as below.
>> <Location /svn>
>>   DAV svn
>>   SVNParentPath /var/lib/svn
>>   SVNAutoversioning on
>>   <LimitExcept GET PROPFIND OPTIONS REPORT>
>>      # Require SSL connection for password protection.
>>      # SSLRequireSSL
>> 
>>      AuthType Basic
>>      AuthName "Authorization Realm"
>>      AuthUserFile /etc/httpd/conf.d/svn_auth
>>      Require valid-user
>>   </LimitExcept>
>> </Location>
>> 
>> Then I restarted the httpd and tried to connect via client,
>> but the result was same. Still cannot connect.


Mime
View raw message