subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Sperling <s...@elego.de>
Subject Re: Problem in connecting the server
Date Tue, 05 Jun 2012 09:55:10 GMT
On Tue, Jun 05, 2012 at 06:42:46PM +0900, Masaru Kitajima wrote:
> I'm not sure if I have a connection problem. As "Yum" and "wget"
> works well on the server. And I can connect to the server using
> HTTP, FTP, and SSH.

If I understood correctly you are having trouble connecting *from*
the server to svn.apache.org, and that you can connect fine to
svn.apache.org from another machine. Or did I misunderstand?

> And I'm not behind any proxies. Only one thing which is different
> is that it's a VPS. But the VPS has a global IP address and I can
> configure almost everything.

Maybe something between svn.apache.org and the VPS is interfering?
Maybe your iptables rules on the VPS are somehow blocking or breaking
outgoing http connections?

I hope you'll find out what's wrong. I cannot think of anything
else to suggest :(

> Ah, I'm really confusing. Is there any specific port I should open
> using iptables for Subversion HTTP connection besides 80?

Subversion uses just port 80 for HTTP.

BTW, I'm getting occasional bounces when sending replies to your posts:

  Final-Recipient: RFC822; kitajima@prime-kobo.com
  Action: failed
  Status: 4.4.7
  Remote-MTA: DNS; prime-kobo.com
  Diagnostic-Code: SMTP; 451 4.3.5 Server configuration error
  Last-Attempt-Date: Tue, 5 Jun 2012 11:31:05 +0200

I don't know what this means and if it is related to the Subversion trouble
you're having.

Mime
View raw message