subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Sperling <s...@elego.de>
Subject Re: Problem in connecting the server
Date Fri, 01 Jun 2012 10:55:56 GMT
On Thu, May 31, 2012 at 10:46:08PM -0700, Masaru Kitajimam wrote:
> Hi, Stefan
> I looked /var/log/httpd/access_log and found an error.
> 
> XXX.XXX.XXX.XXX - kitajima [30/May/2012:16:14:26 +0900] "GET /svn/
> project1 HTTP/1.1" 301 249 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X
> 10_7_4) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/
> 534.57.2"
> 
> This looks like that /svn/project1 is moved permanently. But, /var/lib/
> svn/project1 does exist.(In subversion.conf, I define "SVNParentPath /
> var/lib/svn").
> 
> In the error_log, I found the line
> [Thu May 31 16:51:38 2012] [error] [client XXX.XXX.XXX.XXX] Could not
> fetch resource information.  [301, #0]
> [Thu May 31 16:51:38 2012] [error] [client XXX.XXX.XXX.XXX] Requests
> for a collection must have a trailing slash on the URI.  [301, #0]
> 
> I tried again with slash at the end of the svn URI, but it didn't work
> and showed the same error message.
> 
> Can you find any information?

This looks like a HTTPD configuration problem, or a problem with
the repository URL you're trying to use.

Do you have a RedirectMatch anywhere in your config that misroutes
requests to the /svn location? (In case your configuration is split across
several files, do not just check the svn.conf file -- the *entire* httpd
config needs to be considered).

In your earlier post, http://svn.haxx.se/users/archive-2012-05/0295.shtml,
you said this:
  And I created repository as below:
  # mkdir -p /var/lib/svn/
  # svnadmin create /var/lib/svn/project
  # chown -R apache:apache /var/lib/svn/project

Now you're showing logs that say you're accessing '/svn/project1',
not '/svn/project'. Are you sure you are using the correct URL?
Does the URL you use to access the repository work in a web browser?

Mime
View raw message