subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Finkelstein <jus...@redwiredesign.com>
Subject Re: Issue with upgrade/server move to 1.7.1
Date Mon, 05 Dec 2011 08:55:39 GMT
Yeah; I'd posted this just before we spoke.

Thanks again!

On Sun, 2011-12-04 at 22:40 +0200, Daniel Shahaf wrote:

> Fixed on #svn, right?
> 
> Justin Finkelstein wrote on Sun, Dec 04, 2011 at 16:24:30 +0000:
> > Hi guys
> > 
> > Today I've moved my SVN repository from 1.5.1 to 1.7.1, located on a new
> > server. Having done this, I've upgraded the repositories served and am
> > getting an odd error when testing.
> > 
> > On the server, I'm running: 
> > 
> >     svnserve -d -r /home/svn --foreground --listen-port 3690
> > 
> > When I try to check out or commit on one of my clients:
> > 
> >     svn co svn://toejamfootball/redwire/templates
> >     svn: Network connection closed unexpectedly
> > 
> > On the server, I'm seeing the following: 
> > 
> >     svnserve: subversion/libsvn_subr/dirent_uri.c:956: svn_dirent_join:
> > Assertion `svn_dirent_is_canonical(component, pool)' failed.
> > 
> > I've had a look through previous mailing list posts, tried two different
> > versions of subversion for my target OS (CentOS 6) and have found no
> > solution or clues on how to address this.
> > 
> > Any thoughts? This is a bit of a 'blocking' issue and, in my mind, needs
> > to be posted to the bugs database.
> > 
> > Thanks,
> > 
> > Justin
> > 
> > -- 
> > Redwire Design Limited
> >  
> > 54 Maltings Place
> > 169 Tower Bridge Road
> > London SE1 3LJ
> > www.redwiredesign.com
> > 


-- 
Redwire Design Limited
 
54 Maltings Place
169 Tower Bridge Road
London SE1 3LJ
www.redwiredesign.com
 
[ 020 7403 1444 ] - voice
[ 020 7378 8711 ] - fax
[ 07968 180 720 ] - mobile

Mime
View raw message