subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Himanshu Raina <>
Subject Re: error while restoring repository from dump
Date Thu, 01 Jul 2010 10:57:10 GMT
The dump file gives the same error on the old machine as well (i.e if I try to restore the
repository on the old server I get the same error).
I don't see  \015 in the repository. Another thing, the revision number at which it stops
doesn't seem to have anything that has "\015".
RegardsHimanshu Raina
--- On Thu, 1/7/10, Daniel Shahaf <> wrote:

From: Daniel Shahaf <>
Subject: Re: error while restoring repository from dump
To: "Himanshu Raina" <>
Date: Thursday, 1 July, 2010, 3:47 PM

Himanshu Raina wrote on Thu, 1 Jul 2010 at 12:02 -0000:
> Hi,
> Since I was moving to a new server, I dumped existing repository data using 
> svnadmin dump /pathto/repos > data.dump
> Next I create a new repository on the new server and tried to load data using
> svnadmin load /pathto/repos < data.dump
> While loading data it gave me the following error.
> <<< Started new transaction, based on original revision 105 svnadmin: Invalid
control character '0x0d' in path 'branches/test01/htdocs/property/\015'

I'd like to know if the \015 (LF) is part of the pathname in the
original repository.  Can you check that?

Can you compare the data.dump file on the old/new server, to make sure
nothing changed its line endings en route?  (try SHA-1 or something else
that doesn't ignore whitespace)

> Any idea how can this be resolved. I tried excluding this path  using svndumpfilter
but it didn't help either.

How exactly did you run svndumpfilter?  Try excluding one of the parents
of this path.

> RegardsHimanshu Raina

View raw message