subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Weintraub <qazw...@gmail.com>
Subject Re: HELP! Can't commit anymore: svn: PROPFIND ... Service Unavailable
Date Mon, 18 Jan 2010 15:49:32 GMT
Okay, this is late. I see you're using Apache as your transaction
engine, you're using SUSE, and you're using an old version of
Subversion. Sounds frightfully familiar. We use to have a similar
setup.

Are your repositories read/writable by the HTTP process? On SUSE,
these have to be read/writable by user 'wwwrun'. All files under your
repository directory need to be owned and read/writable by "wwwrun".

We had similar issues where files and directories were suddenly owned
by "root". We never traced down the issue, but we moved over to Redhat
and updated Subversion server to the most recent copy.

On Tue, Jan 12, 2010 at 7:34 PM, Peter Koellner <peter@asgalon.net> wrote:
> Hi!
>
> I am working on a slightly outdated OpenSuSE system that has
> subversion 1.4.4 installed.
> Since an hour or so, I can't do any commits anymore. Everything else
> seems to work, but no commits.
>
> I even checked out a fresh working copy with
>
> svn co http://localhost/svn/meinefc/branches/RELEASE-BETA test
>
> which worked, but all I get on commit is:
>
> Hinzufügen     meinefc/test.txt
> svn: Übertragen fehlgeschlagen (Details folgen):
> svn: PROPFIND Anfrage fehlgeschlagen auf
> »/svn/meinefc/branches/RELEASE-BETA/sites/all/modules/meinefc/test.txt«
> svn: PROPFIND von
> »/svn/meinefc/branches/RELEASE-BETA/sites/all/modules/meinefc/test.txt«:
> 503 Service unavailable (http://localhost)
> svn: Ihre Logmeldung wurde in einer Temporärdatei abgelegt:
> svn:    '/home/koellpe/test/sites/all/modules/svn-commit.tmp'
>
>
> Everything else works. checkout, update, access but no commit!
> I have restarted apache, and I don't see any error
> messages. Everything worked until an hour ago, there were no
> configuration changes.
>
> There are no log messages, no further error messages, no verbose
> messages, no debug messages.
>
> Does anybody have any idea how to solve this? This is extremely
> urgent, since I am in the middle of a very complicated product
> update and had to put the web site offline until finishing this update
> operation
>
>
> --
> peter koellner <peter@asgalon.net>
>



-- 
David Weintraub
qazwart@gmail.com

Mime
View raw message