subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: How to disable lz4 support when library is installed in system?
Date Sat, 14 Apr 2018 16:39:58 GMT
> >  What should I pass to "configure" to PREVENT detection & usage of lz4
> > library installed in system? `--without-lz4' doesn't work.

Yes, I can reproduce this.  '--without-lz4' results in:

configure: lz4 configuration via prefix
checking for LZ4_compress_default in -llz4... yes

which is not the intended behaviour.  The intended behaviour in that case is to throw an AC_MSG_ERROR:

      AC_MSG_ERROR([Subversion requires LZ4 >= r129, or use --with-lz4=internal])

CCing dev@ for this part.

> --with-lz4=internal  may be what you want.
> 
> From what I can gather lz4 is the future so I would be surprised if you 
> can prevent it’s usage.

In principle, if svn were built without lz4 (which isn't supposed to be
allowed by the stock configure) then it won't be able to read or produce
svndiff2 deltas, which are used on the wire and may be used in FSFS f8
on-disk data.

Mime
View raw message