On Nov 17, 2015 8:07 AM, "Philip Martin" <philip.martin@wandisco.com> wrote:
>
> Philip Martin <philip.martin@wandisco.com> writes:
>
> > James McCoy <jamessan@debian.org> writes:
> >
> >> On Mon, Nov 09, 2015 at 12:15:51AM -0500, James McCoy wrote:
> >>> On Sat, Nov 07, 2015 at 10:09:37PM -0500, James McCoy wrote:
> >>> > The attached patch, however, at least gets the test suite working with
> >>> > the test-unit gem, which is a pre-requisite for testing against Ruby
> >>> > 2.2.
> >>>
> >>> Updated to fix a typo in Makefile.in.
> >>
> >> Ping?
> >
> > Doesn't work on my Debian/stable box if I have the ruby-minitest package
> > installed. I think check_rb() is failing with:
> >
> > /usr/lib/ruby/2.1.0/test/unit.rb:676:in `<class:Runner>': undefined method `_run_suite' for class `Test::Unit::Runner' (NameError)
> >
> > If I don't have ruby-minitest installed then the tests work.  It appears
> > that ruby comes with minitest 4.7.5 and that works, but ruby-mintest
> > installs 5.4.2 and that fails.
>
> Hmm, the same problem affects the current code so this is not a new
> problem introduced by your patch.

Yeah, if you install the ruby-minitest gem, you also need to install the ruby-test-unit gem.

Mixing the built-in version of one with the gem version of the other doesn't work well, due to the behavior changes.

Cheers,
James