subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Zhakov <i...@visualsvn.com>
Subject Re: Subversion 1.9.1 and SVNParentPath
Date Thu, 03 Sep 2015 09:09:50 GMT
On 3 September 2015 at 11:18, Branko ─îibej <brane@wandisco.com> wrote:
> On 03.09.2015 09:42, Tony Butt wrote:
>> Problem: Cannot access svn repos using SVNParentPath and subversion
>> 1.9.1
>>
>> Environment:
>> Ubuntu 14.04, Apache 2.4.7, Subversion 1.9.1, mod_auth_kerb
>>
>> Apache config snippet:
>>
>> <Location /repos/>
>>
>>    DAV svn
>>    SVNParentPath /srv/svn/repos/
>>    SVNListParentPath on
>>
>>    SVNIndexXSLT "/svnindex.xsl"
>>
>> # Compression options
>>    AddOutputFilterByType DEFLATE text/html text/plain text/xml
>>    SetInputFilter DEFLATE
>>
>> # Krb Authentication
>>    Include /etc/apache2/krb.conf
>>
>>    AuthDBMType default
>>    AuthDBMGroupFile /srv/www/groupsdb
>>    <RequireAll>
>>      Require group software hardware
>>      Require valid-user
>>    </RequireAll>
>>
>>    AuthZSVNAccessFile /srv/svn/access
>>
>>
>> </Location>
>>
>>
>> I installed the subversion 1.9.0 RC a little while back on this machine,
>> all OK.
>> Installed subversion 1.9.0 release Monday, had to set
>> --enable-broken-httpd-auth
>> to build successfully. Went to the apache config and ensured that no
>> unauthenticated access was possible to the document root. All OK.
>>
>> I installed subversion 1.9.1 yesterday, built and installed OK.
>> On testing repos access, I can browse to http://hostname/repos/ ,
>> but any attempt to access http://hostname/repos/name1
>> fails, with this message at the browser.
>>
>> "Unauthorized This server could not verify that you are authorized to
>> access the document requested. Either you supplied the wrong credentials
>> (e.g., bad password), or your browser doesn't understand how to supply
>> the credentials required."
>>
>> Reverting to Subversion 1.8.13, or 1.9.0 resolves this.
>> Changing the configuration top not use SVNParentPath, by specifying
>> individual repositories with SVNPath resolves this too.
>> Some interaction between the svnauthz changes and SVNParentPath seems to
>> be broken
>
> When you upgraded Subversion, did you also restart httpd? (Using
> 'apachectl graceful' or 'apachectl restart' or reasonable equivalent.)
>
The only relevant change in Subversion 1.9.1 compared to 1.9.0 is 1698052 [1]:
[[[
Merge the r1687304 group from trunk:

 * r1687304,1687389,1693135,1693138,1693159,1695600,1695606,1695681
   Better configure detection of httpd version and auth fix.
   Justification:
     Build out-of-the box on more platforms.
   Votes:
     +1: philip, stefan2, brane
]]]

[1] http://svn.apache.org/viewvc?view=revision&revision=1698052

-- 
Ivan Zhakov

Mime
View raw message