subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Fuhrmann <stefan.fuhrm...@wandisco.com>
Subject Re: Bulk copying revprops
Date Mon, 31 Aug 2015 19:21:02 GMT
On Sat, Aug 29, 2015 at 3:18 PM, Evgeny Kotkov <evgeny.kotkov@visualsvn.com>
wrote:

> Stefan Fuhrmann <stefan.fuhrmann@wandisco.com> writes:
>
> > Because most of the infrastructure for dump-revprops and load-revprops is
> > already in place, I'll give it a go and commit a straightforward
> > implementation.
>
> As of r1698382, I am seeing a segmentation fault every time I try to use
> svnadmin load-revprops with an existing dump:
>
>     0000000000000000()
>     svnadmin.exe!svn_repos_parse_dumpstream3() Line 501
>     svnadmin.exe!svn_repos_load_fs_revprops() Line 1485
>     svnadmin.exe!subcommand_load_revprops() Line 1562
>     svnadmin.exe!sub_main() Line 2959
>     svnadmin.exe!main() Line 2992
>     ...
>

Thanks for the bug report!


> Perhaps the infrastructure isn't exactly ready to be used with null vtable
> entries like svn_repos_parse_fns3_t.new_node_record?
>

If we allow any type of dump stream to be fed into load-revprops,
the parser apparently requires all callback functions to be non-NULL.
r1700180 fixes that problem.

I committed the failing test for this behavior in r1700035.
>

That one passes now. I also added a test for dump-revprops so
that new svnadmin subcommands should be covered now.

-- Stefan^2.

Mime
View raw message