subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan <luke1...@gmx.de>
Subject Re: detach.py script isn't updated for 1.8/1.9
Date Mon, 17 Aug 2015 21:50:17 GMT
Hi,
> Stefan Sperling <stsp@elego.de> writes:
>
>> On Mon, Aug 17, 2015 at 11:03:12AM +0100, Philip Martin wrote:
>>> The script was an experiment that was never finished.
> I was wrong, the script does handle SQLite indices as it copies the
> entire schema.  The main problem is we don't really know how well it
> works or exactly what has to change to update it.
>
>> Why don't we just remove it?
> It was an experiment and it got forgotten.
Thanks for the insight, Philip.

So I guess the question remains, whether it should be removed or not and 
if it is removed whether it should also be removed from 1.8 and 1.9.

I can just provide some thoughts from the users point of view here, in 
case u want to take that into account for ur decision:
The script as it stands right now is not usable with any of the three 
versions (1.8, 1.9, 1.10). It simply doesn't work without modification 
on the WC. Therefore to a user it looks like it's bugged.

That leaves it with the single usage of acting as some means of 
documentation for someone to approach the use-case to detach part of a WC.
Given that there is no other way to do this with the core SVN version, 
it would not be unreasonable to keep that script for this purpose.

So guess there would be three options to go:
1. make the detach-script compatible with 1.8/1.9 and provide this in a 
bugfix release
2. add some documentation to the script to point out it's an experiment 
and can be used as a starting point, if someone needs the functionality 
and cannot use a different approach
3. drop the script

Regards,
Stefan

Mime
View raw message