subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Foad <julianf...@btopenworld.com>
Subject cannot install mod_dontdothat.la to a directory not ending in /home/.../lib/apache2/modules
Date Mon, 11 Feb 2013 15:38:40 GMT
I am getting an error from 'make install-tools' on current trunk:

[[[
$ (cd obj-dir && make install-tools)
/usr/bin/install -c -d /home/.../bin/svn-tools
cd tools/diff ; /bin/bash /.../libtool --mode=install /usr/bin/install -c diff /home/.../bin/svn-tools/diff
libtool: install: /usr/bin/install -c .libs/diff /home/.../bin/svn-tools/diff
[...]
if true ; then cd tools/server-side/mod_dontdothat ; /bin/bash /.../libtool --mode=install
/usr/bin/install -c mod_dontdothat.la /home/.../bin/svn-tools/mod_dontdothat.la ; fi
libtool: install: error: cannot install `mod_dontdothat.la' to a directory not ending in /home/.../lib/apache2/modules
]]]

I see a possible problem in build-outputs.mk -- mod_dontdothat is listed twice in 'install-tools',
with two different commands:

[[[
install-tools: tools/diff/diff$(EXEEXT) ... tools/server-side/mod_dontdothat/mod_dontdothat.la
... tools/server-side/mod_dontdothat/mod_dontdothat.la
        $(MKDIR) $(DESTDIR)$(toolsdir)
        cd tools/diff ; $(INSTALL_TOOLS) diff$(EXEEXT) $(DESTDIR)$(toolsdir)/diff$(EXEEXT)
        ...
        if $(INSTALL_APACHE_MODS) ; then cd tools/server-side/mod_dontdothat ; $(INSTALL_TOOLS)
mod_dontdothat.la $(DESTDIR)$(toolsdir)/mod_dontdothat.la ; fi
        ...
        if $(INSTALL_APACHE_MODS) ; then cd tools/server-side/mod_dontdothat ; $(MKDIR)
"$(APACHE_LIBEXECDIR)" ; $(INSTALL_MOD_SHARED) -n dontdothat mod_dontdothat.la ; fi
]]]

I build in a separate directory (symlinked as 'obj-dir' in the source tree).

I install into ~/local/subversion-a and specify --with-apache-libexecdir=~/local/subversion-a/lib/apache2/modules.

My configure command is:
configure --enable-maintainer-mode --prefix=/home/julianfoad/local/subversion-a --disable-static
--with-apache-libexecdir=/home/julianfoad/local/subversion-a/lib/apache2/modules --disable-mod-activation
--with-ssl --with-serf=/usr --with-gnome-keyring --with-ctypesgen=/home/julianfoad/src/ctypesgen
--enable-javahl --with-junit=/usr/share/java/junit4.jar --with-jdk=/usr/lib/jvm/java-6-sun
--with-sqlite=/home/julianfoad/src/sqlite-amalgamation-3071300/sqlite3.c --with-apr=/home/julianfoad/local/apr-1
--with-apr-util=/home/julianfoad/local/apr-util-1 'CFLAGS=[...]'

I am stuck at this point as I don't understand the installation process well enough.

Note that I renamed 'makefile.ezt' to 'build-outputs.mk.ezt' in r1444822 while trying to trace
where this comes from.

- Julian


--
Certified & Supported Apache Subversion Downloads: http://www.wandisco.com/subversion/download

Mime
View raw message