subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: [PATCH] Remove NLS check from kwallet.m4 (was Re: Does KWallet support really need NLS on?)
Date Mon, 03 Sep 2012 18:51:15 GMT
Daniel Shahaf wrote on Mon, Sep 03, 2012 at 19:44:45 +0100:
> Raphael Kubo da Costa wrote on Mon, Sep 03, 2012 at 08:15:11 -0300:
> > Daniel Shahaf <d.s@daniel.shahaf.name> writes:
> > 
> > > Arfrever Frehtes Taifersar Arahesis wrote on Sun, Sep 02, 2012 at 22:11:11
+0200:
> > >> We need to decide if we support GCC <4.3.0 on GNU systems.
> > >
> > > Can't kwallet.m4 only require --enable-nls if the compiler is gcc <4.3 ?
> > 
> > Or if building some version of Arfrever's test code fails? Speaking of
> > that, isn't the problem of disabling NLS, including
> > svn_private_config.h and risking including something else which may use
> > libintl.h independent of the kwallet code?
> 
> I think the correct fix is to include headers in the correct order ---
> in this case, to move the kwallet includes (which are "external library",
> ie, neither svn's code nor OS/libc) up within kwallet.cpp.

... and, rereading your mail, to ensure that we do that elsewhere in
Subversion, too.

Mime
View raw message