subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Sperling <s...@elego.de>
Subject Re: sqlite3 3.7.11 breaks svnversion: E200030: sqlite: callback requested query abort
Date Sat, 21 Apr 2012 16:51:20 GMT
On Sat, Apr 21, 2012 at 07:49:37AM -0500, Hyrum K Wright wrote:
> On Fri, Apr 20, 2012 at 10:15 PM, Greg Stein <gstein@gmail.com> wrote:
> > Seems we can/should have a runtime version check? Avoid running with 3.7.11?
> 
> I dunno.  Arguably, there are bugs in many versions of our dependency
> libraries which affect us, yet we don't special case them out.  By the
> time anybody upgrades their Subversion to obtain the version check,
> they'll probably have upgraded their SQLite as well, so I don't see it
> as a very big issue.

I think we should block or at least warn about dependencies with known
bugs. There should be a way to force use of the dependency if necessary
(like the --disable-neon-version-check option).

Whether or not a given system has version A of dependency X is often
not a direct decision made by the system's users. For example, a buggy
dependency might slip into a long-term supported release of systems
people use (Debian stale, Redhat, and the like). It's better to make
packagers aware of known problems at build time, rather than waiting
for users of the packages to find problems and file duplicate reports.

Mime
View raw message