subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Corveleyn <jcor...@gmail.com>
Subject Re: Failing test svnsync_tests.py 28: copy and reencode non-UTF-8 svn:* props
Date Thu, 01 Sep 2011 22:02:27 GMT
On Tue, Aug 30, 2011 at 11:29 PM, David Darj <zid@alagazam.net> wrote:
> On 2011-08-28 20:34, Johan Corveleyn wrote:
>>
>> Hi,
>>
>> I get a test failure of svnsync_tests.py 28: copy and reencode
>> non-UTF-8 svn:* props. The following error appears:
>>
>> svnsync: E720087: Can't convert string from 'ISO-8859-3' to 'UTF-8':
>> svnsync: E720087: 2011-01-11T20:57:24.206641Z
>>
>> See also fails.log in attachment.
>>
>> This happens on 1.7.x as well as on trunk. On Windows XP (Visual C
>> Express 2008).
>>
>> ISTR that this error is already there for quite some time, but I
>> didn't yet take the time to investigate further (and my build
>> environment was broken for some time). I guess it has something to do
>> with r1084335, which introduced functionality to let svnsync translate
>> properties that were not encoded in UTF-8.
>>
>> Is anyone else seeing this? Any ideas?
>>
> I've also seen this on my VC6 build for beta3.
> Didn't give it any attention then as it's "just a beta".
> Would be nice if anyone have any clues to the reason.
>
> /David a.k.a Alagazam
>

Any of the other Windows devs seen this? If not, could it be a
difference in compiler or OS, or different set of dependencies?

Any idea what could be the cause, and what to do about it?

FYI, I used these dependencies:
Httpd 2.2.19
Apr 1.4.5 (as included with httpd)
Apr-Util 1.3.12 (as included with httpd)
Apr-Iconv 1.2.1 (as included with httpd)
Neon 0.29.6
OpenSSL 1.0.0d
Serf 1.0.0
SQLite 3.7.7.1
ZLib 1.2.5

Build environment: Visual C++ 2008 Express on Windows XP SP3.

-- 
Johan

Mime
View raw message