subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bert Huijben" <b...@qqmail.nl>
Subject RE: svn upgrade fails with database table is locked
Date Tue, 23 Aug 2011 12:18:53 GMT


> -----Original Message-----
> From: Markus Schaber [mailto:m.schaber@3s-software.com]
> Sent: dinsdag 23 augustus 2011 8:31
> To: Ivan Zhakov; Bert Huijben
> Cc: dev@subversion.apache.org
> Subject: AW: svn upgrade fails with database table is locked
> 
> Hi,
> 
> Von: Ivan Zhakov [mailto:ivan@visualsvn.com]
> 
> > > I did try with
> > >
> > > D:\svntest\brokenwc>"C:\Program Files\VisualSVN\bin\svn.exe" --
> version
> > > svn, version 1.7.0-beta3 (Beta 3)
> > >   compiled Aug 12 2011, 13:22:42
> > >
> > > The result is that the upgrade fails with a different error message:
> > >
> > > D:\svntest\brokenwc>"C:\Program Files\VisualSVN\bin\svn.exe"
> upgrade
> > > Upgraded '.'
> > > Upgraded 'Device'
> > > Upgraded 'Device\Plc Logic'
> > > Upgraded 'Device\Plc Logic\Application'
> > > Upgraded 'Device\Plc Logic\Application\Library Manager'
> > > svn: E155010: The node
> 'D:\svntest\brokenwc\.svn\tmp\wcng\Device\Plc
> > Logic\Application\PLC_PRG\svnobj' was not found.
> > >
> > >
> > It's very interesting. It seems that disabling SQLite shared cache fixes
> > one problem and discovers another. I'm not WCNG expert, may be other
> > Subversion developers have more knowledge of possible reason of "The
> node
> > .. was not found" error.
> >
> > Bert do you have any ideas why this could happen?
> 
> Again, I offer to send the zipped working copy to interested developers.
> (7zip is 19kb, zip is 114kb).

Ok, I found the cause for this issue. Our upgrade code doesn't handle 'svn lock'-locks stored
in the working copy correctly.

I'm working on a fix, but I'm getting some lunch before continuing.

	Bert


Mime
View raw message