subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bert Huijben" <b...@qqmail.nl>
Subject RE: trunk failing tests on Windows XP (32 bit): prop-tests.py 33, stat-tests.py 5, upgrade-tests.py 11
Date Sat, 02 Oct 2010 09:24:55 GMT


> -----Original Message-----
> From: Paul Burba [mailto:ptburba@gmail.com]
> Sent: vrijdag 1 oktober 2010 15:46
> To: Bert Huijben
> Cc: Johan Corveleyn; Subversion Development
> Subject: Re: trunk failing tests on Windows XP (32 bit): prop-tests.py
> 33, stat-tests.py 5, upgrade-tests.py 11
> 
> On Thu, Sep 30, 2010 at 8:10 PM, Bert Huijben <bert@qqmail.nl> wrote:
> >> -----Original Message-----
> >> From: Johan Corveleyn [mailto:jcorvel@gmail.com]
> >> Sent: vrijdag 1 oktober 2010 1:51
> >> To: Subversion Development
> >> Subject: trunk failing tests on Windows XP (32 bit): prop-tests.py
> 33,
> >> stat-tests.py 5, upgrade-tests.py 11
> >>
> >> Hi devs,
> >>
> >> The following tests fail on my machine (Windows XP 32-bit, built
> with
> >> VCE 2008, ra_local):
> >>
> >> - prop-tests.py 33: test properties of obstructed subdirectories
> >> svn: Can't open directory
> >>
> 'C:\research\svn\client_build\svn_trunk\Release\subversion\tests\cmdlin
> >> e\svn-test-work\working_copies\prop_tests-33\A\C':
> >> The directory name is invalid.
> >>
> >> - stat-tests.py 5: status on versioned items whose type has changed
> >> svn: Can't open directory
> >>
> 'C:\research\svn\client_build\svn_trunk\Release\subversion\tests\cmdlin
> >> e\svn-test-work\working_copies\stat_tests-5\A':
> >> The directory name is invalid.
> >>
> >> - upgrade_tests.py 11: missing directories and obstructing files
> >> svn: Can't open directory
> >>
> 'C:\research\svn\client_build\svn_trunk\Release\subversion\tests\cmdlin
> >> e\svn-test-work\working_copies\upgrade_tests-11\A\D':
> >> The directory name is invalid.
> >>
> >> They all seem to try to open some path as a directory, but it isn't
> a
> >> directory (but an empty file or something).
> >>
> >> Am I the only one seeing this? Is this known/normal?
> >
> > This seems to be related to the APR version you use. (Paul Burba
> reported
> > this same problem earlier this week).
> 
> Hi Johan,
> 
> Bert is correct, I saw these failure earlier this week while using APR
> 1.3.12.  All the failures occur when a file unexpectedly obstructs a
> directory.  The APR macro APR_STATUS_IS_ENOTDIR in 1.3.x does not
> handle the "ERROR_DIRECTORY 267 The directory name is invalid" that
> Windows raises in this case.  This was fixed in APR in
> http://svn.apache.org/viewvc?view=revision&revision=821306 and is in
> APR 1.4.2.

I think we should just add this error to the SVN__APR_STATUS_IS_ENOTDIR() macro to fix compatibility
with older apr versions, but I would like to know why this didn't fail a few weeks ago. (I
haven't been very active for the last week, but I haven't seen any relevant commits on the
commit list in the last few weeks)

	Bert
> 
> Paul


Mime
View raw message