subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Swatosh <joe.swat...@gmail.com>
Subject Re: 1.6.8 up for signing / testing
Date Wed, 13 Jan 2010 04:52:06 GMT
Hi

On Tue, Jan 12, 2010 at 2:52 PM, Hyrum K. Wright
<hyrum_wright@mail.utexas.edu> wrote:
> After pulling 1.6.7 due to a segfault regression, we've rerolled the branch as Subversion
1.6.8.  The magic revision is r898464, and you can find the tarballs here:
>
> http://orac.ece.utexas.edu/pub/svn/1.6.8/
>
> Please be sure to test the bindings.
>
> You know the drill: signatures from full committers back to me, and enthusiastic tester
feedback is welcome. At this point, this candidate is not yet blessed for wide release, so
please don't make it available to people not interested in test-driving the new release.
>
> Distro package maintainers, please do NOT include any pre-release builds, even blessed,
into operating system distros.  The reasons for not doing so were very eloquently outlined
by Karl in a mail, which is summarized at the above address.
>
> The quick version is: we don't guarantee compatibility between the pre-releases and the
final release, so if people install the release candidate, all their repositories and working
copies might break irreparably when they upgrade to 1.6.8 proper.   We don't want that kind
of bad publicity, and neither do you.
>

Built and passed when I used the 1.6.1 deps file.

Link failure when using the 1.6.8 deps file:
--------------------Configuration: libsvn_ra_dll - Win32
Release--------------------
Performing Custom Build Step on ..\..\..\build\generator\extractor.py
Compiling resources...
Compiling...
empty.c
Linking...
   Creating library
..\..\..\Release\subversion\libsvn_ra/libsvn_ra-1.lib and object
..\..\..\Release\subversion\libsvn_ra/libsvn_ra-1.exp
libneon.lib(ne_socket.obj) : error LNK2001: unresolved external symbol
_inet_aton
..\..\..\Release\subversion\libsvn_ra\libsvn_ra-1.dll : fatal error
LNK1120: 1 unresolved externals
Error executing link.exe.

__SWIG_RUBY__ - 2 error(s), 51 warning(s)
rake aborted!
Command failed with status (2): [C:\Users\joe-swatosh\Documents\SVN/BuildSc...]



MS windows vista
MSVC6 sp6
Feb 2003 SDK
Ruby 1.8.6

--
Joe

Mime
View raw message