subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hyrum K. Wright" <hyrum_wri...@mail.utexas.edu>
Subject Ruby test failure on 1.6.x
Date Mon, 11 Jan 2010 15:07:11 GMT
After merging the pending fixes into 1.6.x, I reran the tests.  The only failure was in the
ruby bindings:

[[[
hwright@orac:~/dev/svn-1.6.x$ make check-swig-rb
cd /home/hwright/dev/svn-1.6.x/subversion/bindings/swig/ruby; \
	  /usr/bin/ruby -I /home/hwright/dev/svn-1.6.x/subversion/bindings/swig/ruby \
	    /home/hwright/dev/svn-1.6.x/subversion/bindings/swig/ruby/test/run-test.rb \
	    --verbose=normal
Loaded suite .
Started
...................................................................................................................E.......................................................................................................
Finished in 18.84964 seconds.

  1) Error:
test_apply(SvnDeltaTest):
ArgumentError: NULL pointer given
/home/hwright/dev/svn-1.6.x/subversion/bindings/swig/ruby/svn/util.rb:86:in `svn_txdelta_apply_wrapper'
/home/hwright/dev/svn-1.6.x/subversion/bindings/swig/ruby/svn/util.rb:86:in `txdelta_apply_wrapper'
/home/hwright/dev/svn-1.6.x/subversion/bindings/swig/ruby/svn/delta.rb:54:in `apply'
/home/hwright/dev/svn-1.6.x/subversion/bindings/swig/ruby/test/test_delta.rb:128:in `test_apply'

219 tests, 1490 assertions, 0 failures, 1 errors
make: *** [check-swig-rb] Error 1
]]]

I hate to keep picking on the ruby bindings, but if somebody familiar with the bindings could
take a look that'd be great.  I'd rather fix this before we roll than have to re-roll pending
the fix.

Thanks,
-Hyrum
Mime
View raw message