subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Collins-Sussman <suss...@red-bean.com>
Subject Re: svnsync "207 Multi-Status" failure with http access method and property "svn:"
Date Tue, 05 Jan 2010 03:17:58 GMT
Is svnserve really allowing you to create a random svn: junk property?
 I was pretty sure that servers validated svn: properties -- only a
scant few exist, and users aren't supposed to be able to invent them.
My guess is that apache is throwing an error (207 mult-status probably
contains a 5XX code inside it somewhere) when it fails validate the
outgoing svn:asdf property, and then the svn client chokes on the
error.

On Mon, Jan 4, 2010 at 10:36 AM, Kylo Ginsberg <kylo@kylo.net> wrote:
> Self-bump and post to dev list also.  Posting 2 days before Christmas
> seems to be a bad way to get a response ... ;>
>
> On Wed, Dec 23, 2009 at 1:13 PM, Kylo Ginsberg <kylo@kylo.net> wrote:
>> Preparatory to setting up a proxy server, I'm trying to svnsync a
>> repository from 1.6.6 server to another 1.6.6 server (both x86_64
>> linux, one Fedora 7, one Fedora 12).  Some user somehow managed to
>> create a property "svn:" on a file and the svnsync fails like so:
>>
>> Transmitting file data .svnsync: At least one property change failed;
>> repository is unchanged
>> svnsync: PROPPATCH of
>> '/svn-proxy-sync/!svn/wrk/82bb957d-3816-45ed-a262-dadb63d80787/users/jwhiteman/python/cfg/CFG.xml':
>> 207 Multi-Status (http://hood)
>>
>> I'm able to reproduce (what I assume is) the same problem without svnsync:
>> 1) create a repo, with both svn and http access methods
>> 2) via svn access method create a file, set an "svn:" property, and
>> commit it, e.g.
>>  svn co svn://snow/test test
>>  cd test/
>>  echo foo > foo.txt
>>  svn add foo.txt
>>  svn ps svn: asdf foo.txt
>>  svn ci -m testing
>> 3) now try to access it via http:
>>> svn pl http://snow/test/foo.txt
>> svn: PROPFIND of '/test/!svn/bc/1/foo.txt': 207 Multi-Status (http://snow)
>>
>> So two questions here:
>> 1) Is this a known issue? (I didn't see it in the bug db.)  If not,
>> can I get a second nomination that this is a bug?  (If someone can
>> point me in the right direction, and if this is likely to be a
>> somewhat surgical fix, I'd be happy to attempt a patch.)
>> 2) Any recommendations on how to proceed?  For the initial sync of
>> repos I can probably force the issue by svnsync'ing via the svn access
>> method, but I don't think this will work once I set up write-through
>> proxying.
>>
>> Thanks!
>> Kylo
>>
>

Mime
View raw message