subversion-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From james...@apache.org
Subject svn commit: r1831895 - in /subversion/trunk: build/ac-macros/java.m4 build/generator/gen_win.py configure.ac subversion/bindings/javahl/README
Date Sat, 19 May 2018 14:48:35 GMT
Author: jamessan
Date: Sat May 19 14:48:35 2018
New Revision: 1831895

URL: http://svn.apache.org/viewvc?rev=1831895&view=rev
Log:
Bump minimum JDK version required for JavaHL to 1.8, in preparation for the
changes needed to support Java 10

* subversion/bindings/javahl/README
  (): Update JDK version requirements.

* configure.ac
  (JAVA_OLDEST_WORKING_VER): Set to 1.8

* build/ac-macros/java.m4
  (SVN_FIND_JDK): Set Java source version to 1.8.

* build/generator/gen_win.py
  (get_proj_sources): Set Java source and target version to 1.8.

Modified:
    subversion/trunk/build/ac-macros/java.m4
    subversion/trunk/build/generator/gen_win.py
    subversion/trunk/configure.ac
    subversion/trunk/subversion/bindings/javahl/README

Modified: subversion/trunk/build/ac-macros/java.m4
URL: http://svn.apache.org/viewvc/subversion/trunk/build/ac-macros/java.m4?rev=1831895&r1=1831894&r2=1831895&view=diff
==============================================================================
--- subversion/trunk/build/ac-macros/java.m4 (original)
+++ subversion/trunk/build/ac-macros/java.m4 Sat May 19 14:48:35 2018
@@ -166,7 +166,7 @@ AC_DEFUN(SVN_FIND_JDK,
     # The release for "-source" could actually be greater than that
     # of "-target", if we want to cross-compile for lesser JVMs.
     if test -z "$JAVAC_FLAGS"; then
-      JAVAC_FLAGS="-target $JAVA_OLDEST_WORKING_VER -source 1.6"
+      JAVAC_FLAGS="-target $JAVA_OLDEST_WORKING_VER -source 1.8"
       if test "$enable_debugging" = "yes"; then
         JAVAC_FLAGS="-g -Xlint -Xlint:unchecked -Xlint:serial -Xlint:path $JAVAC_FLAGS"
         if test -z "$JAVAC_COMPAT_FLAGS"; then

Modified: subversion/trunk/build/generator/gen_win.py
URL: http://svn.apache.org/viewvc/subversion/trunk/build/generator/gen_win.py?rev=1831895&r1=1831894&r2=1831895&view=diff
==============================================================================
--- subversion/trunk/build/generator/gen_win.py (original)
+++ subversion/trunk/build/generator/gen_win.py Sat May 19 14:48:35 2018
@@ -375,7 +375,7 @@ class WinGeneratorBase(gen_win_dependenc
 
           cbuild = ("%s -g -Xlint -Xlint:-options " +
                     per_project_flags +
-                    " -target 1.5 -source 1.5 -classpath "
+                    " -target 1.8 -source 1.8 -classpath "
                     " %s -d %s "
                     " -sourcepath %s $(InputPath)") \
                    % tuple(map(self.quote, (javac_exe, classes,

Modified: subversion/trunk/configure.ac
URL: http://svn.apache.org/viewvc/subversion/trunk/configure.ac?rev=1831895&r1=1831894&r2=1831895&view=diff
==============================================================================
--- subversion/trunk/configure.ac (original)
+++ subversion/trunk/configure.ac Sat May 19 14:48:35 2018
@@ -1306,7 +1306,7 @@ fi
 AC_PATH_PROGS(PYTHON, "$PYTHON", none)
 
 # The minimum version for the JVM runtime for our Java bytecode.
-JAVA_OLDEST_WORKING_VER='1.6'
+JAVA_OLDEST_WORKING_VER='1.8'
 # SVN_CHECK_JDK sets $JAVA_CLASSPATH
 SVN_CHECK_JDK($JAVA_OLDEST_WORKING_VER)
 

Modified: subversion/trunk/subversion/bindings/javahl/README
URL: http://svn.apache.org/viewvc/subversion/trunk/subversion/bindings/javahl/README?rev=1831895&r1=1831894&r2=1831895&view=diff
==============================================================================
--- subversion/trunk/subversion/bindings/javahl/README (original)
+++ subversion/trunk/subversion/bindings/javahl/README Sat May 19 14:48:35 2018
@@ -5,7 +5,7 @@ JavaHL provides a (mostly native, using
 a high level Java API for Subversion, which was originally targeted for
 implementors of GUI clients and IDE plug-ins for Subversion.  JavaHL
 currently provides a minimal-but-complete set of APIs which expose the
-core Subversion C API to Java.  It requires a JRE 1.6+ (runtime).
+core Subversion C API to Java.  It requires a JRE 1.8+ (runtime).
 
 It is currently quite mature, and can be considered for production use.
 
@@ -14,7 +14,7 @@ Build system
 ------------
 
 JavaHL should compile and run under Linux, Win32, and Mac OS X with
-JDK 1.6+ and a C++ compiler with a complete implementation of
+JDK 1.8+ and a C++ compiler with a complete implementation of
 C++98 (for example, GCC 3.2 and older cannot compile JavaHL 1.9+).
 
 Its build will produce both a native library (libsvnjavahl-1.so on Unix



Mime
View raw message