subversion-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From danie...@apache.org
Subject svn commit: r1825983 - /subversion/site/staging/docs/release-notes/1.10.html
Date Tue, 06 Mar 2018 13:23:28 GMT
Author: danielsh
Date: Tue Mar  6 13:23:28 2018
New Revision: 1825983

URL: http://svn.apache.org/viewvc?rev=1825983&view=rev
Log:
release notes: Tweak the "FSFS f8 is new" bits in the intro.

* staging/docs/release-notes/1.10.html
  (#compatibility): Use the 'notice' box style to make the warning visible and
    to make it harder for us to forget to remove it when the time comes.  Also
    merge the "do not upgrade" language from the existing notice box in #lz4.
  (#new-feature-compatibility-table): LZ4 storage requires 1.10 libraries.
    .
    We may be able to make it more obvious that 1.10's default FSFS format has
    been bumped: after GA, when the notices have been removed, #fsfs-format8
    will be the only place that spells that out.

Modified:
    subversion/site/staging/docs/release-notes/1.10.html

Modified: subversion/site/staging/docs/release-notes/1.10.html
URL: http://svn.apache.org/viewvc/subversion/site/staging/docs/release-notes/1.10.html?rev=1825983&r1=1825982&r2=1825983&view=diff
==============================================================================
--- subversion/site/staging/docs/release-notes/1.10.html (original)
+++ subversion/site/staging/docs/release-notes/1.10.html Tue Mar  6 13:23:28 2018
@@ -84,13 +84,17 @@ Subversion 1.10 servers can read and wri
 earlier versions.  To upgrade an existing server installation, just install the
 newest libraries and binaries on top of the older ones.</p>
 
-<p>Please note that <tt>svnadmin create</tt> will by default create
-repositories using the new <a href="#fsfs-format8">filesystem format 8</a>.
-Until Subversion 1.10 is generally available, <b>no upgrade path is
-promised</b> for repositories with this new filesystem format.  Please do
-not use newly created repositories for any data meant for long-term
-safe-keeping.  See our <a href="/prerelease-caveats">policy for
-pre-releases</a> for additional information.</p>
+<div class="notice">
+  <p><span style="color: red"><b>WARNING:</b></span>
+  Please note that <tt>svnadmin create</tt> will by default create
+  repositories using the new <a href="#fsfs-format8">filesystem format 8</a>.
+  Until Subversion 1.10 is generally available, no upgrade path is
+  promised for repositories with this new filesystem format.  Please do not
+  upgrade your existing repositories used in production, and do not use newly
+  created repositories for any data meant for long-term safe-keeping.  See our
+  <a href="/prerelease-caveats">policy for pre-releases</a> for additional
+  information.</p>
+</div>
 
 <p>Subversion 1.10 maintains API/ABI compatibility with earlier
 releases, by only adding new functions, never removing old ones.  A
@@ -147,7 +151,7 @@ and what impact these changes may have.<
       <a href="#lz4">LZ4 compression in the backend storage</a>
     </td>
     <td>any</td>
-    <td>any</td>
+    <td>1.10</td>
     <td>1.10</td>
     <td>FSFS only</td></tr>
   <tr>



Mime
View raw message