subversion-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rhuij...@apache.org
Subject svn commit: r1786653 - in /subversion/trunk: build/generator/gen_win_dependencies.py gen-make.py
Date Mon, 13 Mar 2017 10:33:04 GMT
Author: rhuijben
Date: Mon Mar 13 10:33:03 2017
New Revision: 1786653

URL: http://svn.apache.org/viewvc?rev=1786653&view=rev
Log:
Add Microsoft Visual Studio 2017 support to our build scripting.

* gen-make.py
  (_usage_exit): Document new support.
  
* build/generator/gen_win_dependencies.py
  (parse_options): Add '2017' as explicitly handled option.

Modified:
    subversion/trunk/build/generator/gen_win_dependencies.py
    subversion/trunk/gen-make.py

Modified: subversion/trunk/build/generator/gen_win_dependencies.py
URL: http://svn.apache.org/viewvc/subversion/trunk/build/generator/gen_win_dependencies.py?rev=1786653&r1=1786652&r2=1786653&view=diff
==============================================================================
--- subversion/trunk/build/generator/gen_win_dependencies.py (original)
+++ subversion/trunk/build/generator/gen_win_dependencies.py Mon Mar 13 10:33:03 2017
@@ -259,6 +259,11 @@ class GenDependenciesBase(gen_base.Gener
           self.sln_version = '12.00'
           self.vcproj_version = '14.0'
           self.vcproj_extension = '.vcxproj'
+        elif val == '2017' or val == '15':
+          self.vs_version = '2015'
+          self.sln_version = '12.00'
+          self.vcproj_version = '15.0'
+          self.vcproj_extension = '.vcxproj'
         elif re.match('^20\d+$', val):
           print('WARNING: Unknown VS.NET version "%s",'
                 ' assuming VS2012. Your VS can probably upgrade')

Modified: subversion/trunk/gen-make.py
URL: http://svn.apache.org/viewvc/subversion/trunk/gen-make.py?rev=1786653&r1=1786652&r2=1786653&view=diff
==============================================================================
--- subversion/trunk/gen-make.py (original)
+++ subversion/trunk/gen-make.py Mon Mar 13 10:33:03 2017
@@ -206,7 +206,7 @@ def _usage_exit(err=None):
   print("           Use static openssl")
   print("")
   print("  --vsnet-version=VER")
-  print("           generate for VS.NET version VER (2005-2015 or 9.0-14.0)")
+  print("           generate for VS.NET version VER (2005-2017 or 9.0-15.0)")
   print("           [implies '-t vcproj']")
   print("")
   print(" -D NAME[=value]")



Mime
View raw message