subversion-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From danie...@apache.org
Subject svn commit: r1692448 - in /subversion/trunk: INSTALL Makefile.in autogen.sh build/find_python.sh configure.ac subversion/bindings/swig/INSTALL subversion/tests/cmdline/README subversion/tests/cmdline/svntest/__init__.py
Date Thu, 23 Jul 2015 21:44:46 GMT
Author: danielsh
Date: Thu Jul 23 21:44:46 2015
New Revision: 1692448

URL: http://svn.apache.org/r1692448
Log:
Require Python ≥2.7 for Subversion 1.9, part 1: documentation and dependency
version checks.

* INSTALL
  (I.C. Dependencies in Detail):
    Document that Python 2.7 is required.
    Add statement about Python 3.x.

* subversion/tests/cmdline/README,
* subversion/bindings/swig/INSTALL:
    Document that Python 2.7 is required.

* autogen.sh,
* build/find_python.sh,
* configure.ac,
* Makefile.in (check),
* subversion/tests/cmdline/svntest/__init__.py:
    Update comments, version number checks, and error messages.

Modified:
    subversion/trunk/INSTALL
    subversion/trunk/Makefile.in
    subversion/trunk/autogen.sh
    subversion/trunk/build/find_python.sh
    subversion/trunk/configure.ac
    subversion/trunk/subversion/bindings/swig/INSTALL
    subversion/trunk/subversion/tests/cmdline/README
    subversion/trunk/subversion/tests/cmdline/svntest/__init__.py

Modified: subversion/trunk/INSTALL
URL: http://svn.apache.org/viewvc/subversion/trunk/INSTALL?rev=1692448&r1=1692447&r2=1692448&view=diff
==============================================================================
--- subversion/trunk/INSTALL (original)
+++ subversion/trunk/INSTALL Thu Jul 23 21:44:46 2015
@@ -446,13 +446,14 @@ I.    INTRODUCTION
       is done: See section III for details.
 
 
-      10.  Python 2.5 or newer (http://www.python.org/)  (OPTIONAL)
+      10.  Python 2.7 or newer (http://www.python.org/)  (OPTIONAL)
 
       If you want to run "make check" or build from the latest source
       under Unix/Windows as described in section II.B, II.E and III.D,
-      install Python 2.5 or higher on your system. The majority of the
+      install Python 2.7 or higher on your system. The majority of the
       test suite is written in Python, as is part of Subversion's build
       system.
+
       Note that Python 3.x is not supported and most likely won't work.
 
 
@@ -763,7 +764,7 @@ II.   INSTALLATION
         is compatible with VC6, which is the one from February 2003.
         You can get it from MSDN:
         https://social.msdn.microsoft.com/Forums/windowsdesktop/en-US/e1147034-9b0b-4494-a5bc-6dfebb6b7eb1/download-and-install-microsoft-platform-sdk-febuary-2003-last-version-with-vc6-support?forum=windowssdk
-      * Python 2.5 or higher, downloaded from http://www.python.org/ which is
+      * Python 2.7 or higher, downloaded from http://www.python.org/ which is
         used to generate the project files.
         Note that Python 3.x is not supported (yet).
       * Perl 5.8 or higher from http://www.activestate.com/

Modified: subversion/trunk/Makefile.in
URL: http://svn.apache.org/viewvc/subversion/trunk/Makefile.in?rev=1692448&r1=1692447&r2=1692448&view=diff
==============================================================================
--- subversion/trunk/Makefile.in (original)
+++ subversion/trunk/Makefile.in Thu Jul 23 21:44:46 2015
@@ -584,7 +584,7 @@ check: bin @TRANSFORM_LIBTOOL_SCRIPTS@ $
 	            $$flags                                                  \
 	            '$(abs_srcdir)' '$(abs_builddir)' $(TESTS);              \
 	else                                                                 \
-	  echo "make check: Python 2.5 or greater is required,";             \
+	  echo "make check: Python 2.7 or greater is required,";             \
 	  echo "            but was not detected during configure";          \
 	  exit 1;                                                            \
 	fi;

Modified: subversion/trunk/autogen.sh
URL: http://svn.apache.org/viewvc/subversion/trunk/autogen.sh?rev=1692448&r1=1692447&r2=1692448&view=diff
==============================================================================
--- subversion/trunk/autogen.sh (original)
+++ subversion/trunk/autogen.sh Thu Jul 23 21:44:46 2015
@@ -157,11 +157,11 @@ fi
 #
 # Note: this dependency on Python is fine: only SVN developers use autogen.sh
 #       and we can state that dev people need Python on their machine. Note
-#       that running gen-make.py requires Python 2.5 or newer.
+#       that running gen-make.py requires Python 2.7 or newer.
 
 PYTHON="`./build/find_python.sh`"
 if test -z "$PYTHON"; then
-  echo "Python 2.5 or later is required to run autogen.sh"
+  echo "Python 2.7 or later is required to run autogen.sh"
   echo "If you have a suitable Python installed, but not on the"
   echo "PATH, set the environment variable PYTHON to the full path"
   echo "to the Python executable, and re-run autogen.sh"

Modified: subversion/trunk/build/find_python.sh
URL: http://svn.apache.org/viewvc/subversion/trunk/build/find_python.sh?rev=1692448&r1=1692447&r2=1692448&view=diff
==============================================================================
--- subversion/trunk/build/find_python.sh (original)
+++ subversion/trunk/build/find_python.sh Thu Jul 23 21:44:46 2015
@@ -21,9 +21,7 @@
 #
 
 # Required version of Python
-# Python 2.0 = 0x2000000
-# Python 2.4 = 0x2040000
-VERSION=${1:-0x2050000}
+VERSION=${1:-0x2070000}
 
 for pypath in "$PYTHON" "$PYTHON2" "$PYTHON3" python python2 python3; do
   if [ "x$pypath" != "x" ]; then

Modified: subversion/trunk/configure.ac
URL: http://svn.apache.org/viewvc/subversion/trunk/configure.ac?rev=1692448&r1=1692447&r2=1692448&view=diff
==============================================================================
--- subversion/trunk/configure.ac (original)
+++ subversion/trunk/configure.ac Thu Jul 23 21:44:46 2015
@@ -1273,7 +1273,7 @@ AS_HELP_STRING([--enable-gprof],
 
 PYTHON="`$abs_srcdir/build/find_python.sh`"
 if test -z "$PYTHON"; then
-  AC_MSG_WARN([Python 2.5 or later is required to run the testsuite])
+  AC_MSG_WARN([Python 2.7 or later is required to run the testsuite])
   AC_MSG_WARN([or to use the Subversion Python bindings])
   AC_MSG_WARN([])
   AC_MSG_WARN([If you have a suitable Python installed, but not on the])

Modified: subversion/trunk/subversion/bindings/swig/INSTALL
URL: http://svn.apache.org/viewvc/subversion/trunk/subversion/bindings/swig/INSTALL?rev=1692448&r1=1692447&r2=1692448&view=diff
==============================================================================
--- subversion/trunk/subversion/bindings/swig/INSTALL (original)
+++ subversion/trunk/subversion/bindings/swig/INSTALL Thu Jul 23 21:44:46 2015
@@ -80,7 +80,7 @@ Step 1:  Install a suitable version of S
 
              --with-python=/path/to/correct/python/binary
 
-        to the configure script.  You need Python 2.5 or above.
+        to the configure script.  You need Python 2.7 or above.
 
         If you plan to build the Perl bindings, and have a system
         with more than one version of perl installed, you may need
@@ -109,7 +109,7 @@ Step 2:  Build and Install Subversion.
   python executable you used to configure SWIG as above.  If it does not then
   you can specify the correct path by adding PYTHON=/path/to/python or
   PERL=/path/to/perl onto the command line for configure.  For example:
-       ./configure PYTHON=/usr/bin/python2.5 PERL=/usr/bin/perl5.8.0
+       ./configure PYTHON=/usr/bin/python2.7 PERL=/usr/bin/perl5.8.0
 
   If Subversion's ./configure finds a SWIG that it's happy with, then
   it will build special glue libraries to link svn to the swig bindings:

Modified: subversion/trunk/subversion/tests/cmdline/README
URL: http://svn.apache.org/viewvc/subversion/trunk/subversion/tests/cmdline/README?rev=1692448&r1=1692447&r2=1692448&view=diff
==============================================================================
--- subversion/trunk/subversion/tests/cmdline/README (original)
+++ subversion/trunk/subversion/tests/cmdline/README Thu Jul 23 21:44:46 2015
@@ -12,7 +12,7 @@ command-line client.  It has no access t
 looks inside the .svn/ directory; it only performs actions that a
 human user would do.
 
-These tests require Python 2.5 or later.
+These tests require Python 2.7 or later.
 
   [ For more general information on Subversion's testing system,
     please read the README in subversion/tests/. ]

Modified: subversion/trunk/subversion/tests/cmdline/svntest/__init__.py
URL: http://svn.apache.org/viewvc/subversion/trunk/subversion/tests/cmdline/svntest/__init__.py?rev=1692448&r1=1692447&r2=1692448&view=diff
==============================================================================
--- subversion/trunk/subversion/tests/cmdline/svntest/__init__.py (original)
+++ subversion/trunk/subversion/tests/cmdline/svntest/__init__.py Thu Jul 23 21:44:46 2015
@@ -23,11 +23,11 @@
 __all__ = [ ]
 
 import sys
-if sys.hexversion < 0x2050000:
-  sys.stderr.write('[SKIPPED] at least Python 2.5 is required\n')
+if sys.hexversion < 0x2070000:
+  sys.stderr.write('[SKIPPED] at least Python 2.7 is required\n')
 
   # note: exiting is a bit harsh for a library module, but we really do
-  # require Python 2.5. this package isn't going to work otherwise.
+  # require Python 2.7. this package isn't going to work otherwise.
 
   # we're skipping this test, not failing, so exit with 0
   sys.exit(0)



Mime
View raw message