subversion-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rhuij...@apache.org
Subject svn commit: r1660541 - /subversion/trunk/INSTALL
Date Tue, 17 Feb 2015 23:55:11 GMT
Author: rhuijben
Date: Tue Feb 17 23:55:11 2015
New Revision: 1660541

URL: http://svn.apache.org/r1660541
Log:
* INSTALL
  Remove some outdated Windows specifics.
  Building zlib with masm support will give you invalid data, so remove
  from file.

Modified:
    subversion/trunk/INSTALL

Modified: subversion/trunk/INSTALL
URL: http://svn.apache.org/viewvc/subversion/trunk/INSTALL?rev=1660541&r1=1660540&r2=1660541&view=diff
==============================================================================
--- subversion/trunk/INSTALL (original)
+++ subversion/trunk/INSTALL Tue Feb 17 23:55:11 2015
@@ -355,10 +355,6 @@ I.    INTRODUCTION
           Under Windows, you can specify the paths to these libraries by
           passing the options --with-zlib and --with-openssl to gen-make.py.
 
-            ### Is that right? In-tree build of Neon was disabled in r875974.
-                This may now apply to Serf, or else gen-make.py should be
-                updated to remove such options.
-
         c. Using OpenSSL on the Apache server
 
           You can also add support for these features to an Apache httpd
@@ -465,23 +461,7 @@ I.    INTRODUCTION
       script.
 
 
-      12. MASM 6 or newer (Windows only, OPTIONAL)
-
-      The Windows build scripts for Subversion can use the Microsoft
-      Macro Assembler (MASM) to build an optimized version of the ZLib
-      library. Make sure that the version of MASM you use is compatible
-      with the C compiler. If you're using MSVC 6, and don't have MASM 6,
-      a free MASM-compatible assembler is available here:
-
-          http://www.masm32.com/
-
-      You only need ML.EXE and ML.ERR from this distribution.
-
-      The VS.NET installation already contains MASM (but note, that
-      version if MASM is not compatible with MSVC 6).
-
-
-      13. SQLite  (REQUIRED)
+      12. SQLite  (REQUIRED)
 
       Subversion 1.8 requires SQLite version 3.7.12 or above.  You can meet
       this dependency several ways:
@@ -497,26 +477,26 @@ I.    INTRODUCTION
           http://www.sqlite.org/download.html
 
 
-      14. pkg-config  (Unix only, OPTIONAL)
+      13. pkg-config  (Unix only, OPTIONAL)
 
       Subversion uses pkg-config to find appropriate options used
       at build time.
 
 
-      15. D-Bus  (Unix only, OPTIONAL)
+      14. D-Bus  (Unix only, OPTIONAL)
 
       D-Bus is a message bus system. D-Bus is required for support for KWallet
       and GNOME Keyring. pkg-config is needed to find D-Bus headers and library.
 
 
-      16. Qt 4  (Unix only, OPTIONAL)
+      15. Qt 4  (Unix only, OPTIONAL)
 
       Qt is a cross-platform application framework. QtCore, QtDBus and QtGui
       modules are required for support for KWallet. pkg-config is needed
       to find Qt headers and libraries.
 
 
-      17. KDELibs 4  (Unix only, OPTIONAL)
+      16. KDELibs 4  (Unix only, OPTIONAL)
 
       Subversion contains optional support for storing passwords in KWallet.
       KDELibs contains core KDE libraries. Subversion uses libkdecore and libkdeui
@@ -528,13 +508,13 @@ I.    INTRODUCTION
 
           --with-kwallet=/path/to/KDE/prefix
 
-      18. GLib 2  (Unix only, OPTIONAL)
+      17. GLib 2  (Unix only, OPTIONAL)
 
       GLib is a general-purpose utility library. GLib is required for support
       for GNOME Keyring. pkg-config is needed to find GLib headers and library.
 
 
-      19. GNOME Keyring  (Unix only, OPTIONAL)
+      18. GNOME Keyring  (Unix only, OPTIONAL)
 
       Subversion contains optional support for storing passwords in GNOME Keyring.
       pkg-config is needed to find GNOME Keyring headers and library. D-Bus and
@@ -542,7 +522,7 @@ I.    INTRODUCTION
       then pass the '--with-gnome-keyring' option to `configure`.
 
 
-      20. Ctypesgen  (OPTIONAL)
+      19. Ctypesgen  (OPTIONAL)
 
       Ctypesgen is Python wrapper generator for ctypes. It is used to generate
       a part of Subversion Ctypes Python bindings (CSVN). If you want to build
@@ -553,7 +533,7 @@ I.    INTRODUCTION
 
       For more information on CSVN, see subversion/bindings/ctypes-python/README.
 
-      21. libmagic (OPTIONAL)
+      20. libmagic (OPTIONAL)
 
       Subversion's configure script attempts to find libmagic automatically.
       If it is installed in a non-standard location, then use:
@@ -574,7 +554,7 @@ I.    INTRODUCTION
 
         --with-libmagic
 
-      22. Googlemock (OPTIONAL)
+      21. Googlemock (OPTIONAL)
 
       Googlemock can be installed and built in-tree by invoking
 



Mime
View raw message