subversion-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From svn-r...@apache.org
Subject svn commit: r1609001 - in /subversion/branches/1.8.x: ./ STATUS configure.ac
Date Wed, 09 Jul 2014 04:00:12 GMT
Author: svn-role
Date: Wed Jul  9 04:00:12 2014
New Revision: 1609001

URL: http://svn.apache.org/r1609001
Log:
Merge r1593992 from trunk:

 * r1593992
   Remove useless warning about ruby during configure.
   Justification:
     Ruby 1.9 support has been there for a while.  Telling people iff they
     are using Ruby 1.9.3 that the support is new is useless.
   Votes:
     +1: breser, rhuijben, philip

Modified:
    subversion/branches/1.8.x/   (props changed)
    subversion/branches/1.8.x/STATUS
    subversion/branches/1.8.x/configure.ac   (contents, props changed)

Propchange: subversion/branches/1.8.x/
------------------------------------------------------------------------------
  Merged /subversion/trunk:r1593992

Modified: subversion/branches/1.8.x/STATUS
URL: http://svn.apache.org/viewvc/subversion/branches/1.8.x/STATUS?rev=1609001&r1=1609000&r2=1609001&view=diff
==============================================================================
--- subversion/branches/1.8.x/STATUS (original)
+++ subversion/branches/1.8.x/STATUS Wed Jul  9 04:00:12 2014
@@ -220,14 +220,6 @@ Veto-blocked changes:
 Approved changes:
 =================
 
- * r1593992
-   Remove useless warning about ruby during configure.
-   Justification:
-     Ruby 1.9 support has been there for a while.  Telling people iff they
-     are using Ruby 1.9.3 that the support is new is useless.
-   Votes:
-     +1: breser, rhuijben, philip
-
  * r1596866
    Fix another instance of issue #3014, "svn log | head" should not
    print "Write error: Broken pipe"

Modified: subversion/branches/1.8.x/configure.ac
URL: http://svn.apache.org/viewvc/subversion/branches/1.8.x/configure.ac?rev=1609001&r1=1609000&r2=1609001&view=diff
==============================================================================
--- subversion/branches/1.8.x/configure.ac (original)
+++ subversion/branches/1.8.x/configure.ac Wed Jul  9 04:00:12 2014
@@ -1280,10 +1280,6 @@ if test "$RUBY" != "none"; then
       RUBY="none"
       AC_MSG_WARN([The detected Ruby is between 1.9 and 1.9.3])
       AC_MSG_WARN([Only 1.8.x and 1.9.3 releases are supported at this time])
-    elif test \(  "$RUBY_MAJOR" -eq "1" -a "$RUBY_MINOR" -eq "9" -a "$RUBY_TEENY" -eq "3"
\); then
-      #Warn about 1.9.3 support
-      AC_MSG_WARN([WARNING: The detected Ruby is 1.9.3])
-      AC_MSG_WARN([WARNING: Only 1.8.x releases are fully supported, 1.9.3 support is new])
     fi
   else
     AC_MSG_RESULT([no])

Propchange: subversion/branches/1.8.x/configure.ac
------------------------------------------------------------------------------
  Merged /subversion/trunk/configure.ac:r1593992



Mime
View raw message