subversion-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bre...@apache.org
Subject svn commit: r1453166 - /subversion/branches/1.7.x-gssapi-solaris10/build/ac-macros/gssapi.m4
Date Wed, 06 Mar 2013 06:08:11 GMT
Author: breser
Date: Wed Mar  6 06:08:10 2013
New Revision: 1453166

URL: http://svn.apache.org/r1453166
Log:
Solaris does not support the gssapi library option to krb5-config, however
it does have a gssapi implementation.  Requiring us to look for the library
in a well known path.

This is being put on a branch since trunk no longer has gssapi detection
support since it has been moved into serf.

* build/ac-macros/gssapi.m4:
  (SVN_LIB_RA_SERF_GSSAPI): Detect when krb5-config --libs gssapi fails and
    try with krb5-config --libs krb5 and then use -lgss and
    -I/usr/include/gssapi.

Modified:
    subversion/branches/1.7.x-gssapi-solaris10/build/ac-macros/gssapi.m4

Modified: subversion/branches/1.7.x-gssapi-solaris10/build/ac-macros/gssapi.m4
URL: http://svn.apache.org/viewvc/subversion/branches/1.7.x-gssapi-solaris10/build/ac-macros/gssapi.m4?rev=1453166&r1=1453165&r2=1453166&view=diff
==============================================================================
--- subversion/branches/1.7.x-gssapi-solaris10/build/ac-macros/gssapi.m4 (original)
+++ subversion/branches/1.7.x-gssapi-solaris10/build/ac-macros/gssapi.m4 Wed Mar  6 06:08:10
2013
@@ -54,6 +54,17 @@ AC_DEFUN(SVN_LIB_RA_SERF_GSSAPI,
       CFLAGS=""
       SVN_GSSAPI_INCLUDES="`$KRB5_CONFIG --cflags`"
       SVN_GSSAPI_LIBS="`$KRB5_CONFIG --libs gssapi`"
+      if test $? -ne 0; then
+        dnl Some platforms e.g. Solaris 10 don't support the gssapi argument
+        dnl and need krb5 instead.  Since it doesn't tell us about gssapi
+        dnl we have to guess.  So let's try -lgss and /usr/include/gassapi
+        SVN_GSSAPI_INCLUDES="$SVN_GSSAPI_INCLUDES -I/usr/include/gssapi"
+        SVN_GSSAPI_LIBS="`$KRB5_CONFIG --libs krb5` -lgss"
+        if test $? -ne 0; then
+          dnl Both k5b-config commands failed.
+          AC_MSG_ERROR([krb5-config returned an error]) 
+        fi
+      fi
       SVN_GSSAPI_LIBS="`SVN_REMOVE_STANDARD_LIB_DIRS($SVN_GSSAPI_LIBS)`"
       CPPFLAGS="$CPPFLAGS $SVN_GSSAPI_INCLUDES"
       CFLAGS="$old_CFLAGS"



Mime
View raw message