subversion-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From phi...@apache.org
Subject svn commit: r1427786 - /subversion/site/publish/docs/release-notes/1.6.html
Date Wed, 02 Jan 2013 13:45:49 GMT
Author: philip
Date: Wed Jan  2 13:45:49 2013
New Revision: 1427786

URL: http://svn.apache.org/viewvc?rev=1427786&view=rev
Log:
Known problem building 1.6 with KWallet support using GCC 4.7.

* site/publish/docs/release-notes/1.6.html
  (issues, kwallet-gcc-4.7): New.

Modified:
    subversion/site/publish/docs/release-notes/1.6.html

Modified: subversion/site/publish/docs/release-notes/1.6.html
URL: http://svn.apache.org/viewvc/subversion/site/publish/docs/release-notes/1.6.html?rev=1427786&r1=1427785&r2=1427786&view=diff
==============================================================================
--- subversion/site/publish/docs/release-notes/1.6.html (original)
+++ subversion/site/publish/docs/release-notes/1.6.html Wed Jan  2 13:45:49 2013
@@ -51,6 +51,8 @@
       >API changes, improvements, and much language bindings work</a></li>
   <li><a href="#bug-fixes"
       >More than 65 new bug fixes, enhancements</a></li>
+  <li><a href="#issues"
+      >Known issues in the release</a></li>
 </ul>
 
 <p>Apache Subversion 1.6 is a superset of all previous Subversion
@@ -926,6 +928,27 @@ for details.</p>
 
 </div>  <!-- enhancements -->
 
+<div class="h2" id="issues">
+<h2>Known issues in the release
+  <a class="sectionlink" href="#issues"
+    title="Link to this section">&para;</a>
+</h2>
+
+<div class="h3" id="kwallet-gcc-4.7">
+<h3>KWallet GCC 4.7 Compile Error 
+  <a class="sectionlink" href="#kwallet-gcc-4.7"
+    title="Link to this section">&para;</a>
+</h3>
+
+<p>Building Subversion 1.6.20, or earlier, with GCC 4.7 will fail to
+compile when configured to include KDE wallet support. This can be
+fixed by configuring without KDE wallet support, or by building with
+an older GCC, or by patching
+with <a href="http://svn.apache.org/r1345740">r1345740</a> from
+trunk. A fix is likely to be included in any future 1.6.x release.</p>
+
+</div>  <!-- issues -->
+
 <div class="h2" id="svn-1.4-deprecation">
 <h2>Subversion 1.4.x series no longer supported
   <a class="sectionlink" href="#svn-1.4-deprecation"



Mime
View raw message