struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: struts2.5.22 + tiles3.0.8 + commons-beanutils to version 1.9.4
Date Tue, 10 Dec 2019 13:23:13 GMT
wt., 10 gru 2019 o 14:15 <emilu@encs.concordia.ca> napisał(a):
> > Why do you use "CompleteAutoloadTilesListener" ? And as far I see
> > everything works in the Showcase app
>
> My application based on tiles3 + struts. As suggested by
> https://struts.apache.org/plugins/tiles-3/ ,
> CompleteAutoloadTilesListener is used. If there are other config that
> could help set tiles3 + struts, could you help suggest please?

As mentioned on the page:
| This plugin was dropped in Struts 2.5, instead please use Tiles
Plugin which was extended and upgraded to Tiles 3.

So please switch into the Tiles Plugin and all you need is this:

<listener>
  <listener-class>org.apache.struts2.tiles.StrutsTilesListener</listener-class>
</listener>

https://struts.apache.org/plugins/tiles/


Regards
-- 
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message