struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yasser Zamani <yasserzam...@apache.org>
Subject RE: Java 11 support
Date Wed, 23 Jan 2019 07:25:37 GMT


>-----Original Message-----
>From: Paul Zepernick <Paul.Zepernick@healthsmart.com>
>Sent: Friday, January 18, 2019 4:24 PM
>To: Struts Users Mailing List <user@struts.apache.org>
>Subject: RE: Java 11 support
>
>I can confirm that this was the same error I was seeing when trying Java 11 using
>Struts 2.5.18.  It is happening in the convention pluggin on the startup of the
>server when it scans for actions to configure Struts.  It is not a compile issue, but
>happening at runtime.
>

Hi Paul,

Thanks for your time!

Could you please check if any further issue persists with my solution posted in previous mail
in list (beside the workaround for drop-in ASM7 dependency)? I think "This feature requires
ASM7" will vanished with it but I'm not comprehensively sure if any further issue arises after.
If so, it would be nice to fix them in 2.5.21 as well (beside asm.version=7.0).

Thanks in advance!

Kind Regards.
Mime
View raw message